FTP Service Will Not Rub

Discussion in 'Installation/Configuration' started by jonedney, Apr 16, 2012.

  1. jonedney

    jonedney New Member

    Hello Everyone,

    I recently went through the installing ISPConfig on Ubuntu 10.04 tutorial walkthrough, and the FTP service is not properly working. Below is the SSH error I get.

    Code:
    Restarting ftp server: perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    	LANG = "en_CA.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -H -O clf:/var/log/pure-ftpd/transfer.log -A -E -8 UTF-8 -u 1000 -b -B
    421 Unable to switch capabilities : Operation not permitted
    I am not Linux experienced, I'm installing this instead of using an installer on my VPS, because I want to learn. So I'm not looking for someone to give me the answers, but to point me in the right direction.

    Thank you,
    Jon Edney
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    dpkg-reconfigure locales
    and select the desired locale.
     
  3. jonedney

    jonedney New Member

    Hello Falco.

    Thank you for your help. Below is the output of the code you said to run; seems like it didn't work properly?

    Code:
    [email protected]:~# dpkg-reconfigure locales
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    	LANG = "en_CA.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    [email protected]:~# 
    Thank you,
    Jon
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please ensure that you run:

    sudo su

    before you executed any of the commands or restarted the ftp server. Only the root user can do these tasks.
     
  5. jonedney

    jonedney New Member

    Till,

    The server I am working on is a VPS that I have root access to. All commands have been ran as 'root', so I didn't think sudo was needed?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. jonedney

    jonedney New Member

    Hello,

    I am receiving this below error.

    Code:
    [email protected]:~# apt-get source pure-ftpd
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: You must put some 'source' URIs in your sources.list
    [email protected]:~#
    Can anyone shine some light on this one?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if the source package repositorys are not configured on your server. Please post the content of the file:

    /etc/apt/sources.list
     

Share This Page