FTP-server problems

Discussion in 'Installation/Configuration' started by Laage, Jul 1, 2010.

  1. Laage

    Laage New Member

    I'm having some problems with FTP-access to sites.

    When I enter the site via the browser I get a listing of six folders (cgi-bin, log, phptmp, ssl, user and web) and an empty passwd.dav file. This is the content of the /var/www/[SITENAME] folder.

    When I log in via FTP I get a listing of two folders (.spamassassin and web) and eleven dot-files. The web-folder contains one index.html file.

    I tried uploading WordPress files to the web-folder via FTP (I thought that the web-folder might be a link) but I'm not seeing any changes in the browser.

    So why am I seeing two distinctly different locations depending on mode of access, and why does the browser show the folders above web? Shouldn't that be the default displayed location?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Is your FTP user the site admin?

    Do you use the web site's domain to access the site, or an IP address or another FQDN?

    Can you post the vhost configuration of that web site? What's the output of
    Code:
    ifconfig
    ?
     
  3. Laage

    Laage New Member

    The FTP-user is the one you create on the User & Email tab on the site configuration. I.e. the web#_*** user.

    To access the FTP i just use the IP-address.
    This is not a live server (yet), so to access the site I use http://10.1.100.54/[HOSTNAME].[DOMAIN].
    I've set up three different sites on the server. One Joomla and one WordPress, where I used the server command line to grab the installation tarballs and untar them directly to the /var/www/[HOSTNAME].[DOMAIN] folders. These two sites display the sites as they should.
    I had a problem earlier that an earlier (uninstalled) wu-ftpd left a line in /etc/inetd.conf which blocked the proftpd used in ISPConfig from running as it should.
    The last site was configured after solving the FTP-server problem and I tried to upload the WordPress MultiUser via FTP. And that's where I'm stuck.

    Here is the ifconfig output:
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:1e:4f:91:05:2c
              inet addr:10.1.100.54  Bcast:10.1.100.255  Mask:255.255.255.0
              inet6 addr: fe80::21e:4fff:fe91:52c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:52549 errors:0 dropped:0 overruns:0 frame:0
              TX packets:19160 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:25866255 (25.8 MB)  TX bytes:3539171 (3.5 MB)
              Memory:fe9e0000-fea00000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:759 errors:0 dropped:0 overruns:0 frame:0
              TX packets:759 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:56745 (56.7 KB)  TX bytes:56745 (56.7 KB)
    
    Can I see the vhost configuration for single sites or do you need to see the apache2.conf file or the vhost-section of the apache2.conf?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, but did you check the admin checkbox for that user in ISPConfig?

    This doesn'T work because ISPConfig configures name-based vhosts, so you must use the FQDN of that web site to access it. You cannot use an IP address.


    Can you post the outputs of
    Code:
    iptables -L
    and
    Code:
    ls -la /root/ispconfig
    ? Did you try both active and passive transfers in your FTP client?
     

Share This Page