FTP-Server problem

Discussion in 'General' started by oldnick, Jan 9, 2009.

  1. oldnick

    oldnick New Member

    Hi,

    I have configured IPConfig 2.2.29 to opensuse 11.1 with this tutorial and i got problem in ftp-server. FTP-server work fine but IPConfig says that FTP-Server are offline and Web-FTP won't work and error "Could not connect to localhost" occured.

    Thanks.
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Don't know that tutorial, but I guess you are usign proftp then?

    Does proftp exist in the processlist (ps -aux)?
    What happens if you manually try to start your ftp-daemon? (in case you are using vsftpd and not proftp, use /etc/init.d/ispconfig_tcpserver as script)
    Any logs of the according ftp server after trying to start it?
    What does netstat -tap show?
     
  3. oldnick

    oldnick New Member

    Yes, proftp

    Code:
    ghetto:~ # ps -ef|grep proftp
    nobody    9934     1  0 Jan08 ?        00:00:00 proftpd: (accepting connections)
    
    ghetto:~ # netstat -tap | grep proftp
    tcp        0      0 *:ftp                   *:*                     LISTEN     9934/proftpd: (acce
    
    FTP service looks like it works fine, acctually i made one Site user and logged in with it, from another network.

    ISPConfig just say that ftp server is offline :(
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the content of the /etc/hosts file
     
  5. oldnick

    oldnick New Member

    Code:
    127.0.0.1       localhost
    
    # special IPv6 addresses
    ::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    127.0.0.2       ghetto.fleikki.com ghetto
    79.141.144.5    ghetto.fleikki.com ghetto
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    iptables -L
    ?
    Did you switch off AppArmor?
     
  7. oldnick

    oldnick New Member

    Code:
    ghetto:~ # iptables -L
    Chain INPUT (policy DROP)
    target     prot opt source               destination
    DROP       tcp  --  anywhere             loopback/8
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTAB                                                     LISHED
    ACCEPT     all  --  anywhere             anywhere
    DROP       all  --  BASE-ADDRESS.MCAST.NET/4  anywhere
    PUB_IN     all  --  anywhere             anywhere
    PUB_IN     all  --  anywhere             anywhere
    PUB_IN     all  --  anywhere             anywhere
    PUB_IN     all  --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    
    Chain FORWARD (policy DROP)
    target     prot opt source               destination
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTAB                                                     LISHED
    DROP       all  --  anywhere             anywhere
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    PUB_OUT    all  --  anywhere             anywhere
    PUB_OUT    all  --  anywhere             anywhere
    PUB_OUT    all  --  anywhere             anywhere
    PUB_OUT    all  --  anywhere             anywhere
    
    Chain INT_IN (0 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    
    Chain INT_OUT (0 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere
    ACCEPT     all  --  anywhere             anywhere
    
    Chain PAROLE (10 references)
    target     prot opt source               destination
    ACCEPT     all  --  anywhere             anywhere
    
    Chain PUB_IN (4 references)
    target     prot opt source               destination
    ACCEPT     icmp --  anywhere             anywhere            icmp destination-un                                                     reachable
    ACCEPT     icmp --  anywhere             anywhere            icmp echo-reply
    ACCEPT     icmp --  anywhere             anywhere            icmp time-exceeded
    ACCEPT     icmp --  anywhere             anywhere            icmp echo-request
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ftp
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ssh
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:smtp
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:domain
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:http
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:81
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:pop3
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:imap
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:https
    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:ndmp
    ACCEPT     udp  --  anywhere             anywhere            udp dpt:domain
    DROP       icmp --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    
    Chain PUB_OUT (4 references)
    target     prot opt source               destination
    ACCEPT     all  --  anywhere             anywhere
    
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Did you switch off AppArmor?

    What are the outputs of
    Code:
    telnet localhost 21
    and
    Code:
    telnet 127.0.0.1 21
    ?

    What's in your proftpd.conf?
     
  9. oldnick

    oldnick New Member

    AppArmor have never been on, checked this anyway :)

    Code:
    ghetto:~ # telnet localhost 21
    Trying ::1...
    telnet: connect to address ::1: Connection refused
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 FTP Server ready.
    Code:
    ghetto:~ # telnet 127.0.0.1 21
    Trying 127.0.0.1...
    Connected to 127.0.0.1.
    Escape character is '^]'.
    220 FTP Server ready.
    /etc/proftpd.conf
    Code:
    ServerName                      "ProFTPD Default Installation"
    ServerType                      standalone
    DefaultServer                   on
    
    # Port 21 is the standard FTP port.
    Port                            21
    
    # Don't use IPv6 support by default.
    UseIPv6                         off
    
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask                           022
    
    MaxInstances                    30
    
    # Set the user and group under which the server will run.
    User                            nobody
    Group                           nogroup
    
    # To cause every FTP user to be "jailed" (chrooted) into their home
    # directory, uncomment this line.
    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready."
    
    # Normally, we want files to be overwriteable.
    AllowOverwrite          on
    
    # Bar use of SITE CHMOD by default
    #<Limit SITE_CHMOD>
    #  DenyAll
    #</Limit>
    
    <Anonymous ~ftp>
      User                          ftp
      Group                         ftp
    
      # We want clients to be able to login with "anonymous" as well as "ftp"
      UserAlias                     anonymous ftp
    
      # Limit the maximum number of anonymous logins
      MaxClients                    10
    
      # We want 'welcome.msg' displayed at login, and '.message' displayed
      # in each newly chdired directory.
      DisplayLogin                  welcome.msg
      DisplayChdir                  .message
    
      # Limit WRITE everywhere in the anonymous chroot
      <Limit WRITE>
        DenyAll
      </Limit>
    </Anonymous>
    
    
    Include /etc/proftpd_ispconfig.conf
    
    /etc/proftpd_ispconfig.conf

    Code:
    DefaultAddress 127.0.0.1
    <VirtualHost 127.0.0.2>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    <VirtualHost 79.141.144.5>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What happens if you comment out the line
    Code:
    Include /etc/proftpd_ispconfig.conf
    in your proftpd.conf and restart ProFTPd?
     
  11. oldnick

    oldnick New Member

    doesn't make any differens.

    from ISPConfig i can shutdown and start proftp and it work like a butter, it's just still say offline :(

    Seem that it can't get right status from proftp or something, wierd
     
  12. falko

    falko Super Moderator ISPConfig Developer

    That's very strange... Must be one of these inscrutable SUSE secrets...
     
  13. reason8

    reason8 Member

    I am having this exact same problem. I left a message in another thread but I am going to delete that one and wait on a reply from where. Thanks!
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Also on a SUSE system? Anything in your logs?
     
  15. reason8

    reason8 Member

    Everything looks normal other than I have instances of bad sectors on my hard disk:

    smartd[3060]: Device: /dev/sda [SAT], 4 Currently unreadable (pending) sectors

    I did notice the bind status reporting dead. I can stop but not start it. There are 2 sites that I have set up and I am getting an error of:

    Starting name server BIND /etc/named.conf:48: zone 'sirkaos.linkpc.net': already exists previous definition: /etc/named.conf:38
    /etc/named.conf:53: zone 'amsico.com': already exists previous definition: /etc/named.conf:42

    I created master, slave and ptr records for these 2. Was that incorrect?
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    maybe you added the domain amsico.com as primary and secondary dns record on the same server. You will have to delete the secondary record then and empty the recycle bin afterwards.
     
  17. reason8

    reason8 Member

    That sounds about right. I deleted everything under dns manager prior to this reply but now when I try to create a master dns record, I get the error,"You already created a domain (SOA Record) with the name amsico.com." I don't think there has been one created.
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Did you empty the recycle bin?
     
  19. reason8

    reason8 Member

    Yes, I did.
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Do you see amsico.com in the dns_isp_dns table?

    Did you install the latest ISPConfig version (2.2.30)?
     

Share This Page