FTP server offline after fresh install

Discussion in 'Installation/Configuration' started by Geoinline, Nov 16, 2005.

  1. Geoinline

    Geoinline New Member

    FTP server is offline in ISPConfig
    I got this error when installing

    Code:
    Restarting ProFTPD ftp daemon..
    .. - getaddrinfo 'mydomain.com' error: Temporary failure in name resolution
     - warning: unable to determine IP address of 'mydomain.com'
     - error: no valid servers configured
     - Fatal: error processing configuration file '/etc/proftpd.conf'
    
    It seems to me that it's failing to get address info for the domain name I entered. Is it possible for me to change the domain to be my IP address? How would I do this?:confused:

    Any help would be appreciated
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Your hostname has to exist in DNS.
    You can either create proper DNS records for your hostname, or give your system another hostname like this:

    Code:
    echo server1.example.com > /etc/hostname
    /bin/hostname -F /etc/hostname
    , or modify /etc/hosts and add your current hostname to the 127.0.0.1 line.
     
  3. Geoinline

    Geoinline New Member

    Got it working

    I just reinstalled again and now it works.:rolleyes:
     
  4. danf.1979

    danf.1979 ISPConfig Developer ISPConfig Developer

    Uhmm, here is my /etc/hostname
    Code:
    alcon
    
    And here is /etc/hosts
    Code:
    127.0.0.1 localhost.localdomain localhost alcon
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    I have configured a domain in ispconfig with this machine: abejasalud.cl (www.abejasalud.cl with NS1 ns1.abejasalud.cl), but that is all. I'm experiencing problems with proftpd... after some time the server gets offline and trys to start with /etc/init.d/proftpd start but it never can, until I reboot. Could this something to do with it?
    Many thanks
     
  5. danf.1979

    danf.1979 ISPConfig Developer ISPConfig Developer

    His /etc/proftpd_ispconfig.conf:
    Code:
    ###################################
    #
    # ISPConfig proftpd Configuration File
    #         Version 1.0
    #
    ###################################
    <VirtualHost 200.104.78.7>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    <VirtualHost 200.104.78.7>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    </VirtualHost>
    
    Maybe the problem is that it should be with something like www.abejasalud.cl or something? And why is it repeated twice?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Do you get any error messages when you try to restart Proftpd? Is there anything in the logs?
     
  7. danf.1979

    danf.1979 ISPConfig Developer ISPConfig Developer

    Nothing strange in the syslog but this:
    Code:
    Dec 20 06:34:39 localhost postfix/smtp[9078]: connect to mx.vtr.net[200.83.1.24]: server refused to talk to me: 554 mx02.vtr.net Service not available - access denied   (port 25)
    Dec 20 06:34:39 localhost postfix/smtp[9078]: 3B5441DDE: to=<abejasalud@vtr.net>, relay=none, delay=107677, status=deferred (connect to mx.vtr.net[200.83.1.24]: server refused to talk to me: 554 mx02.vtr.net Service not available - access denied  )
    
    Code:
    Dec 20 06:35:55 localhost proftpd[9204]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened. 
    Dec 20 06:35:55 localhost proftpd[9204]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - mod_delay/0.4: delaying for 12 usecs 
    .
    .
    .
    Dec 20 06:17:59 localhost proftpd[7890]: localhost.localdomain - ProFTPD killed (signal 15) 
    Dec 20 06:17:59 localhost proftpd[7890]: localhost.localdomain - ProFTPD 1.2.10 standalone mode SHUTDOWN 
    Dec 20 06:18:01 localhost proftpd[8236]: localhost.localdomain - ProFTPD 1.2.10 (stable) (built do mrt 22 18:28:32 CET 2001) standalone mode STARTUP 
    
     
  8. falko

    falko Super Moderator ISPConfig Developer

    The first log entries are for Postfix, not Proftpd.

    Do you see any error messages when you try to restart Proftpd?
     

Share This Page