FTP Server not starting ....

Discussion in 'ISPConfig 3 Priority Support' started by NeonTigerUK, Apr 11, 2017.

  1. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    Just added another new web server to my Multi-Server panel, and it's coming up RED, saying the FTP server isnt running ....

    Code:
    [email protected] /etc/ssl/private # service pure-ftpd-mysql status
    ‚óŹ pure-ftpd-mysql.service - (null)
      Loaded: loaded (/etc/init.d/pure-ftpd-mysql)
      Active: active (exited) since Tue 2017-04-11 11:16:48 CEST; 3min 20s ago
      Process: 1444 ExecStop=/etc/init.d/pure-ftpd-mysql stop (code=exited, status=0/SUCCESS)
      Process: 1453 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status=0/SUCCESS)
    
    Apr 11 11:16:48 web2 pure-ftpd-mysql[1453]: Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf ... -b -H -B
    Apr 11 11:16:48 web2 systemd[1]: Started (null).
    Apr 11 11:16:48 web2 pure-ftpd[1460]: ([email protected]?) [ERROR] Sorry, but that file doesn't exist: [/etc/ssl/private/pure-ftpd.pem]
    Apr 11 11:17:00 web2 systemd[1]: Started (null).
    Hint: Some lines were ellipsized, use -l to show in full.
    
    So I looked for the file, as you can see, it is in the specified path

    Code:
    [email protected] /etc/ssl/private # ll
    total 8
    -rw------- 1 root root     1704 Apr 11 10:49 pure-ftpd.pem
    -rw-r----- 1 root ssl-cert 1704 Apr 11 10:29 ssl-cert-snakeoil.key
    
    Any thoughts?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the file /etc/ssl/private/pure-ftpd.pem, does it contain a ssl key and cert?
     
  3. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    looks like it has the key to me ...
    Code:
    -----BEGIN PRIVATE KEY-----
    MIIEvQIBADANBgkqhkiG9w0BAQEFAASCBKcwggSjAgEAAoIBAQDhcRv5b+XWmfaY
    {24 lines removed}
    w8zy7w0FhoL2av6anfEz8ks=
    -----END PRIVATE KEY-----
    No Certificate though :(
     
    Last edited: Apr 12, 2017
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to chmod the file to e.g. 660 and check if it works then.
     
  5. NeonTigerUK

    NeonTigerUK Member HowtoForge Supporter

    still only a key, still wont start after chmod 660
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ahh ok, did not notice that it's a key only. Redo the steps to create the key and cert from perfect server tutorial to fix that. Most likely you entered something during cert creation that the openssl command did not understand which caused the ssl cert creation to fail.
     

Share This Page