FTP server not responding

Discussion in 'Installation/Configuration' started by aqua, Mar 3, 2006.

  1. aqua

    aqua New Member

    Hello:

    I followed the instructions to setting up the isp server configuration. when i restarted my server, near the end of the startup messages i got the following message:

    Starting ProFTPD ftp daemon: - warning: "ProFTPD" address/port (192.168.10.100:21) already in use by "Debian"
    proftpd.

    I tried to connect to the FTP server, it would connect but it would not log me in, it would say login incorrect, even after several tries.

    I even tried to logon the FTP server from within ispconfig, but it says Could not connect as user xxx

    Finally, i tried the user name and password of my root account on my server, and it worked, but there is nothing listed in that directory.


    Here is an output of my netstat -tap


    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    PID/Program name
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 7
    968/mysqld
    tcp 0 0 *:81 *:* LISTEN 8
    166/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 8
    341/proftpd: (acce
    tcp 0 0 biggie.myvnc.com:domain *:* LISTEN 8
    327/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 8
    327/named
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 8
    327/named
    tcp 0 0 *:smtp *:* LISTEN 8 297/master
    tcp 0 0 biggie.myvnc.com:ftp 192.168.10.103:40129 ESTABLISHED1 0012/proftpd: ala
    tcp6 0 0 *:imaps *:* LISTEN 7 878/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 7 913/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 7 893/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 7 858/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 8 202/apache2
    tcp6 0 0 *:ssh *:* LISTEN 8 106/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 8 327/named
    tcp6 0 0 *:https *:* LISTEN 8 202/apache2
    tcp6 0 288 biggie.myvnc.com:ssh ::ffff:192.168.10:40707 ESTABLISHED1 0193/sshd:


    any help or pointers would be appreciated.
    aqua
     
  2. falko

    falko Super Moderator

    Please put
    Code:
    SocketBindTight on
    into /etc/proftpd.conf and restart ProFTPd.
     
  3. aqua

    aqua New Member

    SocketBindTight on broke my ftp server, and no amount of restarting would get it back up.

    Silly me though, turns out i didn't create ftp and mail accounts for each site. I thought the login information assigned to each client would be a default login... :eek:

    Thanks for the reply though :)
     
  4. falko

    falko Super Moderator

    So it's working now?
     

Share This Page