ftp server for anonymous account asks for password irritating!

Discussion in 'General' started by j.smith19810808, Mar 9, 2010.

  1. j.smith19810808

    j.smith19810808 New Member

    I have installed ispconfig2 on centos4.8.

    It keeps asking for a password when i try ftp://ftp.hsmedia.co.uk

    This is annoying, is there anyway to stop this?:mad:

    You shouldnt have to do this at all, why doesnt the tutorial obviously work?

    I have followed it step by step and its asking for a password, please can someone help me in sorting this out?

    Thanks in advance,
  2. j.smith19810808

    j.smith19810808 New Member

    If this helps I have a log message which might be relevant:

    Not sure if this helps but it's so frustrating!
  3. falko

    falko Super Moderator ISPConfig Developer

    Can you run
    useradd -d /var/www/web9/ftp -g web9_anonftp -m -s /bin/false -u 12009 web9_anonftp
    on the command line? Do you get any errors?
  4. j.smith19810808

    j.smith19810808 New Member

    Thanks for your reply its much appreciated, as always!

    But I think as it says I can only have 1 anonymous account assigned to an IP then I will just setup a normal user for that domain with the password still in the link possibly, like off a webpage for example.

    Is there anyway in the configs say for that virtual ftp server though, to make it so the user isnt able to write to it?

    Ie if they tried adding it to their network neighbourhood in XP or even on Vista (through their way of doing it), is there anyway they can get a denied message if they tried adding a folder?

    I could achieve what I want like that couldnt I?

    Thanks again falko really appreciate your responses, I dont think it would work really the way I want it to, but this is the best solution to do what I want for now anyways.

    Kind regards and I look forward to your reply to my new post,

    PS the response I got back if your still interested is (from command: :

    I did a run of cat for /etc/group and it came up with this at the bottom (sorry was messing around with my mail server settings (ie another post in this forum), and have changed the id of the account to 10 not 9 anymore thats why its coming up with that.

    This is the contents of the group file:
    Last edited: Mar 12, 2010

Share This Page