FTP problems

Discussion in 'Installation/Configuration' started by sageman, Feb 17, 2006.

  1. sageman

    sageman New Member

    Hi there,

    after reinstall of ISPConfig due to a hardware related problem, I can`t Login into any FTP.

    It seems that before the reinstall anonftp was used(at least I found users like web4_anonftp).
    Now, when creating a new Client (with FTP-checkmark), such user is not being created - nor can I log in(new or old accounts).

    Please point me in the right direction - bear in mind, my shell repertoire is quite limited...

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in the ISPConfig logfile for errors:

  3. sageman

    sageman New Member

    OK - here is a warning I get, hope it is relevant:

    17.02.2006 - 14:57:06 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1861: WARNING: could not useradd -d /srv/www/web4/ftp -g web4_anonftp -M -s /bin/false -u 12004 web4_anonftp &> /dev/null
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your /etc/passwd file contains the user web4_anonftp ?
  5. falko

    falko Super Moderator ISPConfig Developer

    Also check the file /home/admispconfig/ispconfig/users if web4_anonftp is in there.
  6. sageman

    sageman New Member

    is there:
  7. sageman

    sageman New Member

    OK - I think I am asking the wrong question:

    Anonymous FTP on the domain belonging to web4 IS possible - but how do I create a "regular" FTP-Login?

    When I hit the Web-FTP button in ISPConfig, I can not login:
    login failed as user ...
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Create a user on the "user & email" tab of the website and use this username and password for login. If you check the administrator checkbox for a user, this user will be able to upload files with FTP to the main website directory.
  9. sageman

    sageman New Member

    Thanks, Till - that was it ...

    I promise to read the manual from front the end - and not just skip over it!

Share This Page