ftp paswword cant log in

Discussion in 'Installation/Configuration' started by fisherofer, Oct 7, 2009.

  1. fisherofer

    fisherofer New Member

    i reinstall pure-ftpd
    i created users but i cant log in
    [[email protected] pure-ftpd-1.0.22]# ftp
    ftp> open localhost
    Connected to localhost.localdomain.
    220---------- Welcome to Pure-FTPd ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 08:54. Server port: 21.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    500 This security scheme is not implemented
    500 This security scheme is not implemented
    KERBEROS_V4 rejected as an authentication type
    Name (localhost:root): [my User]
    331 User[my User] OK. Password required
    Password:
    530 Login authentication failed
    Login failed.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> open localhost
    Already connected to localhost.localdomain, use close first.
    ftp> user
    (username) [my User]
    331 User [my User] OK. Password required
    Password:
    530 Login authentication failed
    Login failed.
    ftp>


    please help and any tips as cancel anonymous user
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. fisherofer

    fisherofer New Member

    thanks i have centos sorry for not writing that
    but this is the log
    and thanks

    GNU nano 1.3.12 File: pureftpd.log

    Oct 7 11:09:40 webvision pure-ftpd: ([email protected]) [INFO] New connection from 62.90.102.234
    Oct 7 11:09:40 webvision pure-ftpd: ([email protected]) [DEBUG] Command [user] [b12_org_iladmin]
    Oct 7 11:09:40 webvision pure-ftpd: ([email protected]) [DEBUG] Command [pass] [<*>]
    Oct 7 11:09:48 webvision pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [b12_org_iladmin]
    Oct 7 11:09:48 webvision pure-ftpd: ([email protected]) [INFO] Logout.
    Oct 7 11:09:59 webvision pure-ftpd: ([email protected]) [INFO] New connection from 62.90.102.234
    Oct 7 11:09:59 webvision pure-ftpd: ([email protected]) [DEBUG] Command [user] [root]
    Oct 7 11:09:59 webvision pure-ftpd: ([email protected]) [DEBUG] Command [pass] [<*>]
    Oct 7 11:09:59 webvision pure-ftpd: ([email protected]) [WARNING] Can't login as [root]: account disabled
    Oct 7 11:10:02 webvision pure-ftpd: ([email protected]) [INFO] Logout.
    Oct 7 11:10:03 webvision pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Oct 7 11:10:03 webvision pure-ftpd: ([email protected]) [DEBUG] Command [quit] []
    Oct 7 11:10:03 webvision pure-ftpd: ([email protected]) [INFO] Logout.
    Oct 7 11:11:38 webvision pure-ftpd: ([email protected]) [INFO] New connection from 62.90.102.234
    Oct 7 11:11:38 webvision pure-ftpd: ([email protected]) [DEBUG] Command [user] [afek123a]
    Oct 7 11:11:38 webvision pure-ftpd: ([email protected]) [DEBUG] Command [pass] [<*>]
    Oct 7 11:11:44 webvision pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [afek123a]
    Oct 7 11:11:44 webvision pure-ftpd: ([email protected]) [INFO] Logout.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. fisherofer

    fisherofer New Member

    # Don't resolve host names in log files. Logs are less verbose, but
    # it uses less bandwidth. Set this to "yes" on very busy servers or
    # if you don't have a working DNS.

    DontResolve yes

    and i didnt change it
     
  6. fisherofer

    fisherofer New Member

    i think this will help

    adduser ftptest
    passwd ftptest

    Changing password for user ftptest.
    New UNIX password:
    BAD PASSWORD: it is too simplistic/systematic
    Retype new UNIX password:
    passwd: all authentication tokens updated successfully


    [[email protected] etc]# ftp
    ftp> open localhost
    Connected to localhost.localdomain.
    220---------- Welcome to Pure-FTPd ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 15:22. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    500 This security scheme is not implemented
    500 This security scheme is not implemented
    KERBEROS_V4 rejected as an authentication type
    Name (localhost:root): ftptest
    331 User ftptest OK. Password required
    Password:
    230-User ftptest has group access to: ftptest
    230 OK. Current restricted directory is /
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp>


    but when i try with ispconfig users i cant log in

    ftp> open
    (to) localhost
    Connected to localhost.localdomain.
    220---------- Welcome to Pure-FTPd ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 15:26. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    500 This security scheme is not implemented
    500 This security scheme is not implemented
    KERBEROS_V4 rejected as an authentication type
    Name (localhost:root): afek123a
    331 User afek123a OK. Password required
    Password:
    530 Login authentication failed
    Login failed.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp>
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then you use a pure-ftpd daemon without mysql support. If you would use the correct daemon, then Linux users wont be able to login.

    Please reinstall pure-ftpd with mysql support as described in the perfect setup guide.
     
  8. fisherofer

    fisherofer New Member

    yum remove pure-ftpd
    Loaded plugins: fastestmirror
    Setting up Remove Process
    Resolving Dependencies
    There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
    --> Running transaction check
    ---> Package pure-ftpd.i386 0:1.0.21-15.el5.kb set to be erased
    --> Finished Dependency Resolution

    Dependencies Resolved

    =============================================================================================================================================================
    Package Arch Version Repository Size
    =============================================================================================================================================================
    Removing:
    pure-ftpd i386 1.0.21-15.el5.kb installed 527 k

    Transaction Summary
    =============================================================================================================================================================
    Install 0 Package(s)
    Update 0 Package(s)
    Remove 1 Package(s)

    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Erasing : pure-ftpd [1/1]
    warning: /etc/pure-ftpd/pureftpd-mysql.conf saved as /etc/pure-ftpd/pureftpd-mysql.conf.rpmsave
    warning: /etc/pure-ftpd/pureftpd-ldap.conf saved as /etc/pure-ftpd/pureftpd-ldap.conf.rpmsave
    warning: /etc/pure-ftpd/pure-ftpd.conf saved as /etc/pure-ftpd/pure-ftpd.conf.rpmsave

    Removed: pure-ftpd.i386 0:1.0.21-15.el5.kb
    Complete!



    yum install pure-ftpd
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * extras: ftp.cc.uoc.gr
    * rpmforge: ftp-stud.fht-esslingen.de
    * base: ftp.cc.uoc.gr
    * updates: ftp.cc.uoc.gr
    * addons: ftp.cc.uoc.gr
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
    --> Running transaction check
    ---> Package pure-ftpd.i386 0:1.0.21-15.el5.kb set to be updated
    --> Finished Dependency Resolution

    Dependencies Resolved

    =============================================================================================================================================================
    Package Arch Version Repository Size
    =============================================================================================================================================================
    Installing:
    pure-ftpd i386 1.0.21-15.el5.kb kbs-CentOS-Testing 236 k

    Transaction Summary
    =============================================================================================================================================================
    Install 1 Package(s)
    Update 0 Package(s)
    Remove 0 Package(s)

    Total download size: 236 k
    Is this ok [y/N]: y
    Downloading Packages:
    pure-ftpd-1.0.21-15.el5.kb.i386.rpm | 236 kB 00:02
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Installing : pure-ftpd [1/1]

    Installed: pure-ftpd.i386 0:1.0.21-15.el5.kb
    Complete!


    chkconfig --levels 235 pure-ftpd on
    /etc/init.d/pure-ftpd start

    and its all i have for pure-ftpd from
    http://www.howtoforge.com/perfect-server-centos-5.2-ispconfig-3
     
  9. fisherofer

    fisherofer New Member

    nano pureftpd-mysql.conf

    # Mandatory : user to bind the server as.

    MYSQLUser root


    # Mandatory : user password. You must have a password.

    MYSQLPassword [root-password]
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The content of pureftpd-mysql.conf is not correct. The user is always named ispconfig in a ispconfig setup. I guess thet the file had been overwritten. Please download the latest ispconfig release and run the update.php script to reconfigure your setup.
     
  11. fisherofer

    fisherofer New Member

    ftp
    ftp> open localhost
    Connected to localhost.localdomain.
    220---------- Welcome to Pure-FTPd ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 16:00. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    500 This security scheme is not implemented
    500 This security scheme is not implemented
    KERBEROS_V4 rejected as an authentication type
    Name (localhost:root): b12orgila
    331 User b12orgila OK. Password required
    Password:
    230-User b12orgila has group access to: client2 sshusers
    230 OK. Current restricted directory is /
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> ls
    227 Entering Passive Mode (127,0,0,1,24,223)
    150 Accepted data connection
    drwxr-xr-x 2 5007 5005 4096 Oct 5 05:44 .
    drwxr-xr-x 2 5007 5005 4096 Oct 5 05:44 ..
    226-Options: -a -l
    226 2 matches total
    ftp>


    thanks its working but i dont see anything

    ls
    227 Entering Passive Mode (127,0,0,1,24,223)
    150 Accepted data connection
    drwxr-xr-x 2 5007 5005 4096 Oct 5 05:44 .
    drwxr-xr-x 2 5007 5005 4096 Oct 5 05:44 ..
    226-Options: -a -l
    226 2 matches total
    ftp>
     
  12. fisherofer

    fisherofer New Member

    i have to update in the ftp users from
    /var/www/clients/[website_domain]/web
    to
    /var/www/clients/*****/web
    and its ok


    and i dont know whay in defoult its adding /var/www/clients/[website_domain]/web[id]
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The correct path for FTP users is:

    /var/www/clients/[website_domain]/web[id]

    and not /var/www/clients/[website_domain]/web[id]/web

    Maybe you dont use the latest ISPConfig version as there was a bug in one of the older beta versions that prevents the access to this directory when the securioty mode is set to strong. Please update to the latest ispconfig version and then edit a setting in the site, e.g. quota and click save so that ispconfig updates the folder permissions.
     
  14. fisherofer

    fisherofer New Member

    i agree its /var/www/clients/[website_domain]/web[id]
    and i want it to be
    /var/www/clients/[website_domain]/web

    and when i change it to
    /var/www/clients/[website_domain]/web
    the ftp user see nothing
    only when i copy past the url from the server
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Then change the sourcecode if you dont like how ISPConfig works.
     
  16. fisherofer

    fisherofer New Member

    i know that i system -- server config i can change the web location
    why its not efected on the ftp ?
    or to add option
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up the root path of the website and the subdirectory which holds the web contant. The root path of the site which you can set in the server settings is the directory above the web directory. By the way, you should not chnage this path as this may cause your system to fail or to be incompatible with future updates. Also you should never use the domain name in the path, only the ID's shall be used. The domain names shall only be used for the symlinks and never for the path itself as you sites might get messed up when you rename the domain of a website.
     
  18. fisherofer

    fisherofer New Member

    i fix it
    as you write i mixed up many things
    thanks for the help
    many thnaks
     

Share This Page