ftp not working

Discussion in 'Installation/Configuration' started by pesja, Jul 17, 2006.

  1. pesja

    pesja New Member

    Hello,

    I am testing ISPConfig. On my testing domain the ftp-access with a ftp-client is not working.
    a ping command give the answer that the ftp.testdomain.com doesn't exist at al.
    I checked the box with ftp-access (not the anonymus one), but no luke. The ISP Web-FTP is working.

    The ISP box is a debian 3.1 with (off course) proftp ftp-server with the normal perfect install.

    Did a portscan an saw that port 21 is open. So that's not the issue.
    I tried to connect with the ftp-client directly at the ipadress with the username+password at that's working well, but that's not what I want.

    I think it's an dns-problem, because my other testdomain is working with external dns-servers and works good when i pinged it of I try to connect at ftp.othertestdomain.com.
    But I looked at the named.conf at testdomain.com and everything looked OK.

    I tried to give the solution by making an A record of the ftp-server as other host control boxes does. I then restart the dns server and wait for several hours. Still no luck. What is wrong?
     
    Last edited: Jul 17, 2006
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If you did not create the DNS A-Record for ftp.mydomain.com on the authoritive nameserver (this can but must not be your ISPConfig server!), you can not reach FTP through this domain.

    Instead of ftp.mydomain.com just use mydomain.com or www.mydomain.com to connect with your FTP client.
     
  3. pesja

    pesja New Member

    Well Till,

    I tried as you said to connect with my ftp-client at www.testdomain.com and it worked well. A little bit strange as it sound, because almost all my life i reached ftp-servers with ftp.testdomain.com, but this will works also. Thank's.

    But the other thing I don't onderstand well. As I read it well, you say that even if I make an A record (ftp xxx.xxx.xxx.xxx) it will not work on my ISP hostserver because my dns server also is installed on it.

    Please correct me if I read above wrong.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    It is a workaround for users to create a additional subdomain like ftp.testdomain.com for FTP, but it is not very common. Maybe you used always the same ISP software that uses this naming scheme.

    DNS records may take up to 48 hours to propagate. Is your server the authoritive nameserver of the domain, it is not enaough to just run a nameserver on your server, it must be also authoritive for the domain.
     

Share This Page