FTP logins failing

Discussion in 'General' started by SyRenity, Nov 20, 2006.

  1. SyRenity

    SyRenity New Member

    Failed FTP logins


    I have installed ISPConfig, must say it looks like a very promising software.

    I have one issue with FTP logins. They worked previously, but for some reason, now I can't login to any site. I tried to delete the sites and recreate them, delete the users and recreate them, and it's the same.

    Each such failed login is accompanied by the following record in /var/log/messages:

    Nov 20 11:32:44 phone proftpd[10850]: phone :):ffff:XXX.XXX.XXX.XXX[::ffff:XXX.XXX.XXX.XXX]) - PAM(n1-business.com_1): Authentication failure.

    (X's are the replaced IP).

    Any idea how it can be diagnosed and resolved?

    Thank you.
    Last edited: Nov 20, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    grep 'n1-business.com_1' /etc/passwd
  3. SyRenity

    SyRenity New Member

    I changed the naming method since this message to the default (site[WEBID]_), which still doesn't work. Here is the output for the new name:

    grep 'site10_admin' /etc/passwd

    Last edited: Nov 21, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    You didn't enable FTP for that web site. Please do so (it's on the Basis tab of that web site in ISPConfig).
  5. SyRenity

    SyRenity New Member

    Thanks a lot! I spent quite a lot of time over this one :).

    Perhaps this should be enabled by default, or somehow explained, as it will be more intutive for people coming from Ensim/Cpanel/HSphere.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It is explained in the manual and in the online help when you click on the "?" behind the checkbox :) Also the name of the option is "FTP Access".

Share This Page