FTP Login problem

Discussion in 'Installation/Configuration' started by chicagowebdev, Sep 19, 2009.

  1. chicagowebdev

    chicagowebdev New Member

    First I couldn't see directories, now I can't login.

    I tried to reinstall pure-ftpd, but that messed it up more :p

    I've check my mysql logs and there are no queries being generated.

    So then I ran the update script from ispconfig's install directory, and it prompted me to reconfiguew services, which i did.

    I still don't see any SQL queries being generated however.

    Great software so far though, thanks for all the hard work, and how to forge is great! :D
  2. chicagowebdev

    chicagowebdev New Member

    I've also just updated from SVN and it's still not letting me login or show any mysql queries.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is most liekly not realted to ISPConfig, its a problem with your FTP daemon. Please post the output of:

    netstat -tap | grep FTP

    and check in ispconfig in the jobqueue if all jobs had been processed.
  4. chicagowebdev

    chicagowebdev New Member

    Indeed, thanks for your reply.

    I got a blank screen from

    netstat -tap | grep FTP
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you installed pure-ftpd as installed in the perfect setup guide for ispconfig 3 and that pure-ftpd is started.
  6. chicagowebdev

    chicagowebdev New Member

    The reason nothing was showing up is because of the uppercase FTP.

    Below is what I see now if i change the netstat switch:
    tcp        0      0 *:ftp                   *:*                     LISTEN      11394/pure-ftpd (SE
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      11394/pure-ftpd (SE
    I've installed everything according to the Pefect Server on Ubunty 9.04 w/ ISPConfig 3

    Any idea why the ftp server won't connect to mysql?

    All I see in mysql log is the moniter data being inserted/deleted
  7. till

    till Super Moderator Staff Member ISPConfig Developer

  8. chicagowebdev

    chicagowebdev New Member

    I'm guessing it's because pure-ftp is using PAM for some reason...
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    ubuntu offers more then one pure-ftpd pacakge. Please make sure that you installed the one with "mysql" in the name iand not the "normal" one which does not has mysql support.
  10. chicagowebdev

    chicagowebdev New Member


    I removed the pure-ftpd package and installed the mysql version, and everything works!

    Thanks so much!


Share This Page