FTP-Login not working

Discussion in 'Installation/Configuration' started by tini, Sep 1, 2009.

  1. tini

    tini New Member

    Hi there

    I just installed ISPConfig 3.0.1.3 on Virtual Machine in VirtualBox (Ubuntu 9.04) following this tutorial: http://www.howtoforge.com/perfect-server-ubuntu-9.04-ispconfig. The server has a LAN-IP, so does my workstation. There should be no firewall issues.

    So I created a new client and for this client i created a new website and a new FTP-user.
    Now the problem is, that this FTP-user can not login. I tried both passive and active conenctions. I even tried a local connection on the server.

    The FTP-user is correctly in the database (table "ftp_user").

    Here is the output of "netstat -tap | grep ftp":

    Code:
    tcp        0      0 *:ftp                   *:*                     LISTEN      2785/pure-ftpd (SER
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      2785/pure-ftpd (SER
    
    The output of my FTP-client:

    Code:
    STATUS:>  	[01.09.2009 18:27:59] Getting listing ""...
    STATUS:>  	[01.09.2009 18:27:59] Resolving host name ispconfig.****.ch...
    STATUS:>  	[01.09.2009 18:27:59] Host name ispconfig.****.ch resolved: ip = 192.168.0.181.
    STATUS:>  	[01.09.2009 18:27:59] Connecting to FTP server... ispconfig.****.ch:21 (ip = 192.168.0.181)...
    STATUS:>  	[01.09.2009 18:27:59] Socket connected. Waiting for welcome message...
    		[01.09.2009 18:27:59] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    		220-You are user number 1 of 50 allowed.
    		220-Local time is now 18:27. Server port: 21.
    		220-This is a private system - No anonymous login
    		220-IPv6 connections are also welcome on this server.
    		220 You will be disconnected after 15 minutes of inactivity.
    STATUS:>  	[01.09.2009 18:27:59] Connected. Authenticating...
    COMMAND:>	[01.09.2009 18:27:59] USER democlient3
    		[01.09.2009 18:27:59] 331 User democlient3 OK. Password required
    COMMAND:>	[01.09.2009 18:27:59] PASS *****
    		[01.09.2009 18:27:59] 530 Login authentication failed
    ERROR:>   	[01.09.2009 18:27:59] Not logged in.
    STATUS:>  	[01.09.2009 18:28:01] Connection closed.
    
    And finally the output of "/var/log/messages":

    Code:
    Sep  1 18:27:59 server1 pure-ftpd: (?@192.168.0.150) [INFO] New connection from 192.168.0.150
    Sep  1 18:27:59 server1 pure-ftpd: (?@192.168.0.150) [WARNING] Authentication failed for user [democlient3]
    Sep  1 18:28:03 server1 pure-ftpd: (?@192.168.0.150) [INFO] Logout.
    
    Does anyone have a clue why this isn't working?

    Thx
     
    Last edited: Sep 1, 2009
  2. till

    till Super Moderator

    Enable logging in mysql and check which SQL queries are sent to the mysql server from pureftpd.
     
  3. tini

    tini New Member

    the following commands are executed. I ran them directly in MySQL and attached its result too:

    Code:
    SELECT password FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
    
    Result: Encrypted password.


    Code:
    SELECT uid FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
    
    Result: web2

    Code:
    SELECT gid FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
    
    Result: client1

    Code:
    SELECT dir FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
    
    Result: /var/www/clients/client1/web2

    Maybe this should go into another thread, but I just had a look at the server and to my surprise the folder "/var/www/clients/client1/web2" does not exist. Any idea why?
     
    Last edited: Sep 2, 2009
  4. till

    till Super Moderator

    Thats ok, pure-ftpd is able to connect to the database and gets some valid results. Please check with:

    grep web2 /etc/passwd


    and

    grep client1 /etc/group

    if the group and user exist. If they dont exist, then edit the website were the ftp user belongs to, e.g. change the quota and click on save. Then wait a minute and check again. You can see in the jobqueue of the monitor if the changes have been applied or if threre were any errors.
     
  5. tini

    tini New Member

    Both commands didn't return anything, so I tried you suggestion.

    I set the Quoto from -1 to 100.
    In the Jobqueue I see the following:

    2009-09-02 10:35 ispconfig.****.ch Update web_domain

    I waited for 10 minutes, but it seems that the user and the group still don't exist.
     
  6. till

    till Super Moderator

    Is the jobqueue empty now or is the update job still there in the queue?
     
  7. tini

    tini New Member

    There are 2.5 pages of update jobs in the Jobqueue.
    This is a problem, isn't it?
     
  8. till

    till Super Moderator

    Yes, then no jobs will be executed. Check if there is a error in the systm-log.
     
  9. tini

    tini New Member

    That's what I thought.

    The list in "Monitor -> Show System-Log" is empty.

    By the way, I changed the server name in /etc/hosts and /etc/hostname after the installation of ISPConfig3.

    But I also changed the server name in "System -> Edit Server" and in "System -> Server Config" I changed the Network Configuration (checkbox "Network Configuration" is selected and the new hostname i correct).

    Does changing the hostname affect ISPConfig?
     
  10. till

    till Super Moderator

    No.

    Please check with:

    ps aux | grep php

    if there are a lot of php processes running from ispconfig.
     
  11. tini

    tini New Member

    There a 72 php processes running from ispconfig.

    By the way, thank you for your support.
     
  12. till

    till Super Moderator

    Then you run most likely into a problem with maildirmake which can cause to block the mailqueue.

    The easiest solution at the moment is to update your ISPConfig version to the current SVN release which fixes this by running the script:

    ispconfig_update.sh

    Or you update to the 3.0.1.4 beat 2 version.
     
  13. tini

    tini New Member

    Ehm, where do I find the update skript on my server?

    Is there a tutorial how to install ISPconfig from SVN and more precisely, to make future use of SVN in order to update the installation?
     
  14. till

    till Super Moderator

    The update script is in your path. Just execute:

    ispconfig_update.sh

    No. Especially as you normally should not use a svn version as its for development and might contain bugs or even destroy your setup. But in your case the fix is not released yet, so there are not so many options to solve it beside using the svn version.
     
  15. tini

    tini New Member

    Allright. So I will run the update skript using SVN as the update method. I'll post later with the results.

    Thank you very much
     
  16. tini

    tini New Member

    Ok, updating from SVN did the trick. So far, FTP-login works and the Jobqueue empties in an acceptable time limit.

    Thx again and keep up the good work.

    By the way, I searched the forums on how to install Ruby On Rails in ISPConfig.
    Are there still any plans to include RoR in ISPconfig?

    I will try to add mod_rails AKA passenger to Apache.

    Oh and one more question: is it safe to update the server (Ubuntu) with aptitude or is there a chance that it will brake the current installation of ISPConfig?
     
  17. till

    till Super Moderator

    Yes. But we have a very long roadmap and new features have to be implemented and tested step by step.

    yes
     
  18. tini

    tini New Member

    Thank you very much for this information.
     

Share This Page