ftp login is to below web server root

Discussion in 'General' started by hairydog2, Oct 30, 2005.

  1. hairydog2

    hairydog2 New Member

    This is the problem: I create a new user called test2, and create a website for test2.com. I create a webuser login called test2user. When I log in using the webftp or a separate ftp program as tes2user, it takes me to


    I upload a file to /home/www/web20/user/test2user/web/ then when I open a browser to look at test2.com I see the default index page.

    And it is easy to see why: if I look in /etc/apache2/vhosts/Vhosts_ispconfig.conf

    the relevant part of the file says:

    ServerName www.test2.com:80
    ServerAdmin [email protected]
    DocumentRoot /home/www/web20/web

    This means that the directory being set up for the user is lower down the path than the webroot; the user can't put files into webroot.

    I followed the Debian 3.1 perfect setup, and I'm running v2.1.0

    What do I change to make it fit together?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to check the "Administrator" checkbox in the settings of the user test2user.
  3. hairydog2

    hairydog2 New Member

    Thanks. That sorted it out. I hadn't worked out why each user has a subdirectory called web.

    I now realise that it is so that each user can have their own web space with the url


    If that's in the documentation, I missed it!

Share This Page