ftp login failed

Discussion in 'Installation/Configuration' started by toux, Sep 24, 2010.

  1. toux

    toux New Member

    Hi all,

    Some weeks ago, I was updated from 3.0.1 to 3.0.2 and now I opened some sites and ftp users, I try connect to FTP, and Filezilla says:
    Response: 530 Login authentication failed

    I check on phpmyadmin ispconfig Db and I check ftp users and the user appear well.

    I don't know what can be the problem.

    Thank you !
     
  2. till

    till Super Moderator

  3. toux

    toux New Member

    Sep 24 17:58:24 ks33222 kernel: BANDWIDTH_IN:IN=eth0 OUT= MAC=00:1c:c0:4a:1b:67:00:d0:d3:35:0e:94:08:00 SRC=83.231.23.109 DST=198.235.164.56 LEN=70 TOS=0x00 PREC=0x00 TTL=50 ID=36648 DF PROTO=TCP SPT=42509 DPT=21 WINDOW=108 RES=0x00 ACK PSH URGP=0
    Sep 24 17:58:24 ks33222 pure-ftpd: (?@92.291.23.119) [WARNING] Authentication failed for user [c0avila]
    Sep 24 17:58:24 ks33222 kernel: BANDWIDTH_OUT:IN= OUT=eth0 SRC=198.235.164.56 DST=83.231.23.109 LEN=85 TOS=0x10 PREC=0x00 TTL=64 ID=54053 DF PROTO=TCP SPT=21 DPT=42509 WINDOW=91 RES=0x00 ACK PSH URGP=0

    I can read this

    Thnak you!

    David
     
  4. lucani

    lucani New Member

    I think that c0avila isn't your correct login, default ftp prefix is [CLIENTNAME] not c[CLIENTID] as in database. If your client name is "firstclient" and you created ftp account "avila", your correct ftp login would be "firstclientavila" and password as you typed in new FTP-User.

    -------------------
    P.S. I use "[CLIENTNAME]_" (with " _ ") as default FTP prefix so ftp logins are more clear e.g. "company_user". Till, do you think it isn't better? Maybe this small change is worth fast modification in next version of ISPConfig?
    -------------------
     
    Last edited: Sep 24, 2010
  5. toux

    toux New Member

    Hi Lucani,

    Thank you for your reply, but when I configure the Ispconfig I delete the prefixs on interface config, I prefer user my own users, and I don use users the server is for my sites.

    I checked on phpmyadmin ispconfig db the user and is the same c0avila is correct, i don know what can be the problem.

    Thank you for your help
     
  6. lucani

    lucani New Member

    I see.

    I don't know if I understood you, but MySQL database accounts and FTP user accounts are separate things. I'm not sure also if you checked right table. It should be: phpmyadmin > dbispconfig > ftp_user > field "username"

    If c0avila is correct username, login into ISPConfig control panel > Sites > FTP-User, write once again your password and save - maybe you missclicked during last entering password ?
     
  7. toux

    toux New Member

    Hi Lucani,

    Thank you for your reply!

    No I try with 123 for example and not enter, I change the pass, I delete the site, I delete the ftp-user and create it another time, and nothing.

    I don know what can be the problem, in my other servers with ispcnfig i never had this problem.

    Thank you!
     
  8. till

    till Super Moderator

  9. toux

    toux New Member

    I disable the disable name resolving

    I found ftp_user table

    I see the correct user, password is encripted, do you if is in MD5 format ot other I see $ symbol.

    I check when I change the pass on the ispconfig format the code of the pass change.

    Thnak you!
     
  10. Festinalente

    Festinalente New Member

    Numeric user causes error

    I had the similar error message. I was experimenting with ISPConfig 3 and had created a user called 1. After changing the name from numeric into characters the error message disappeared.

    :)
     
  11. till

    till Super Moderator

    It is not in md5. All passwords are in crypt-md5 format with salt, they always start with 4. If this password looks different, then you might hve it entered manually as you tested FTP? You should enter the password again in ispconfig and wait a minute until ispconfig has updated the database.
     
  12. toux

    toux New Member

    Hello Till, thank you for your reply,

    Accesing to ssh, on var folder I can not see the folder of the sites. May be this the problem?
    :(

    Thank you
     
  13. thibotus01

    thibotus01 New Member

    Hey,

    Can't get authentification either :(

    I activated the debug, but I only have :
    Edit : test & login.test & login.domain.fr work.
    But : login.test.domain.fr doesn't work.

    some bug?
     
    Last edited: Oct 2, 2010

Share This Page