ftp login doesn't work when using md5 ?

Discussion in 'Installation/Configuration' started by bbrendon, May 30, 2008.

  1. bbrendon

    bbrendon New Member

    If I'm using md5 instead of crypt, users can not login using FTP and probably other things. If I manually set their password from the unix prompt, everything works, but setting passwords using the web interface only works when passwords are set to crypt.

    Does this have something to do with PAM? I appear to have md5 enabled in PAM.

    /etc/pam.d/common-password :
    password required pam_unix.so nullok obscure min=4 max=8 md5
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not support md5 passwords, it supports only crypt-md5.
  3. bbrendon

    bbrendon New Member

    I guess thats what I meant. The comment in the config file says to specify md5. I currently have it set to crypt, because when I set it to md5, I have to set the password from the command line so that FTP authenticates successfully.

    Should I set it = crypt-md5 instead?

    $go_info["server"]["password_hash"] = 'crypt'; // 'crypt' = crypt; 'md5' = crypt-md5
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, md5 is the setting for crypt-md5. It seems as if your system does not support it, so you will have to stay with crypt.
  5. bbrendon

    bbrendon New Member

    Interestingly, it appears that it does. My shadow file:

    They all work fine. The ones that are crypt were set with ispconfig and the md5 ones were set manually.
  6. bbrendon

    bbrendon New Member

    It seems to be working now. I wonder if it has something to do with the characters in the password. Hmmm

Share This Page