FTP Issues on ISPConfig3

Discussion in 'General' started by billcouper81, Jan 29, 2010.

  1. billcouper81

    billcouper81 New Member

    Hi

    Firstly, I'd like to say that I love ISPConfig !!!

    It's a fantastic piece of kit and I think you are doing a marvelous job



    I have an Ubuntu server which I setup using the "Perfect Server Ubuntu 9.04 ISPConfig 3" tutorial a while ago... I have been running it for a while now and everything is peachy... I have many websites and email domains configured, everything is working ok.. or at least, I thought it was...

    I have been noticing lately that I get many many errors when connected via FTP.
    It will connect and display the DIR contents, but then when I try to transfer files or change directories, it reconnects to the server and this doesn't work.

    I have tried both passive and active transfer modes and I have tried it from the local LAN and from the outside world.


    In FileZilla, this is a sample of the error messages:

    Command: PWD
    Response: 257 "/web" is your current location
    Command: PORT 192,168,168,105,4,220
    Response: 200 PORT command successful
    Command: MLSD
    Response: 150 Connecting to port 43684
    Response: 226-ASCII
    Response: 226-Options: -l
    Response: 226 5 matches total
    Status: Directory listing successful
    Status: Resolving address of ategra.com.au
    Status: Resolving address of ategra.com.au
    Status: Connecting to 202.173.141.238:21...
    Status: Connection established, waiting for welcome message...
    Status: Connecting to 202.173.141.238:21...
    Status: Connection established, waiting for welcome message...
    Error: Could not connect to server
    Status: Delaying connection for 5 seconds due to previously failed connection attempt...
    Error: Could not connect to server
    Status: Delaying connection for 5 seconds due to previously failed connection attempt...

    In that example, I connected and it displayed the DIR contents, I then immediately tried to drag/drop the files to transfer and already it has to reconnect to the server

    I am still only running ISPConfig 3.0.1.3 but I do run apt-get upgrade once a week.... will I see any difference if I upgrade my version of ISPConfig? Or is there something else going on here? I've tried searching google and here but haven't found anyone with the same problem



    UPDATE: I just found the update instructions for ISPConfig3 and it's extremely easy to do lol... so I have updated to 3.0.1.6 and still having the same problem
     
  2. till

    till Super Moderator

    Please check the syslog and messages log and post the error messages that you get there.
     
  3. prisfeo

    prisfeo New Member

    hi,
    right that problem i had time ago..
    not related to ispconfig but to a firewall "in between" client ad ftp server issue
    that oblige client ftp sw to be set in passive mode
    i have solved installing on the client an ftp client sw supporting
    the setting of passive mode
    note i said "client" ad not "server ftp sw" cause the problem
    was not on the server(already set in passive mode cause the FW), but in the ftp sw of the client
    (was a ftp command in windows server that is known to be affected by this limitation)
    ..
    maybe it can be related to your problem:rolleyes:
     
    Last edited: Jan 29, 2010
  4. prisfeo

    prisfeo New Member

    stupid question:
    did you try to make a ftp test session
    inside the ispconfig server or inside a machine in the same local net ?
    so bypassing any fw issue/sw..etc..
     
  5. billcouper81

    billcouper81 New Member

    Thankyou to everyone for your responses

    @Till
    In /var/log/messages I don't see any errors for pure-ftpd
    In /var/log/syslog I am seeing the following error for pure-ftpd:
    pure-ftpd: (?@?) [ERROR] Sorry, invalid address given

    I am connecting to the server via it's hostname (eg. domain.com.au) which is a valid ISPConfig site on this server (no problems on the web access). What is strange is it seems to be random. Sometimes I can connect fine, sometimes it says invalid address.



    @Prisfeo
    I have tested both active and passive transfer modes on the client software. I have also tried limiting the amount of simultaneous connections that FileZilla opens to just 1.

    I don't really know how to make a test ftp session inside the server or on the local network... as far as I was aware I can only connect via FTP if I specify a valid domain name for the server address... I can't just connect to it's local IP address (even though I am on the same LAN) or I get nothing but the "Invalid address" error.

    I have tested with many different domain names that are sites on this ISPConfig server and it is always the same: randomly getting invalid address errors
     
  6. till

    till Super Moderator

  7. billcouper81

    billcouper81 New Member

    till, i want to have your babies


    you are awesome!


    obviously, your fix has worked and now i am excited :)

    cheers!
     
: reconnect, ftp, errors

Share This Page