ftp hanging at MLSD

Discussion in 'Technical' started by kwickcut, Dec 11, 2014.

  1. kwickcut

    kwickcut Member

    i have had my server running for some time and have had no issues oncce it was all set up..

    just today when trying to connect to the ftp it hangs at MLSD and then i get the following message

    Error: Connection timed out
    Error: Failed to retrieve directory listing

    there has been no changes to anything on the server side.. what should i be looking at to resolve this problem..

    this is the log in display message when attempting to log into the ftp

    Error:Status:	Resolving address of addurad.com
    Status:	Connecting to xx.xxx.xx.xxx:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 1 of 75 allowed.
    Response:	220-Local time is now 00:15. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	AUTH TLS
    Response:	234 AUTH TLS OK.
    Status:	Initializing TLS...
    Status:	Verifying certificate...
    Command:	USER username1
    Status:	TLS/SSL connection established.
    Response:	331 User username1 OK. Password required
    Command:	PASS ********
    Response:	230-User username1 has group access to:  client4    sshusers  
    Response:	230 OK. Current restricted directory is /
    Command:	SYST
    Response:	215 UNIX Type: L8
    Command:	FEAT
    Response:	211-Extensions supported:
    Response:	 EPRT
    Response:	 IDLE
    Response:	 MDTM
    Response:	 SIZE
    Response:	 REST STREAM
    Response:	 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response:	 MLSD
    Response:	 AUTH TLS
    Response:	 PBSZ
    Response:	 PROT
    Response:	 UTF8
    Response:	 ESTA
    Response:	 PASV
    Response:	 EPSV
    Response:	 SPSV
    Response:	211 End.
    Command:	OPTS UTF8 ON
    Response:	200 OK, UTF-8 enabled
    Command:	PBSZ 0
    Response:	200 PBSZ=0
    Command:	PROT P
    Response:	200 Data protection level set to "private"
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is your current location
    Command:	TYPE I
    Response:	200 TYPE is now 8-bit binary
    Command:	PASV
    Response:	227 Entering Passive Mode (68,39,193,54,197,167)
    Command:	MLSD
    Error:	Connection timed out
    Error:	Failed to retrieve directory listing
    thanks for the help

  2. kwickcut

    kwickcut Member

    issue solved.. in the directory


    the ip had somehow been commented... Maybe from some kind of update? anyway its is now working..

    figured someone may have this issue and this is what fixed mine


Share This Page