Ftp, get full access

Discussion in 'General' started by allenmally8, Jan 28, 2010.

  1. allenmally8

    allenmally8 New Member

    Hi how do I get full access to the server using a ftp program (filezilla) can logon as normal but cant access all folders. and cant access some folders using putty?

    Using it for personal use.
    I followed The Perfect Server - Ubuntu 9.10 [ISPConfig 3]
     
  2. yoplait

    yoplait Member

    If you really want that, you can use the sftp protocol and use your root access on this server. (If I understand well ... :S )
     
  3. allenmally8

    allenmally8 New Member

    Worded that badly how do I login as root using firezilla as I can only login as normal using sftp.

    Can login using putty as normal and then typing sudo su and password.

    Im a bit of a newbie to all of this lol.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use winscp.
     
  5. allenmally8

    allenmally8 New Member

    tried winscp and get same error as filezilla attached screen shot, as I would like full control to put files on the server as it takes for ever to upload files going through the internet and it is easyer to use an ftp program to put files on and some of the files I would like to change can only be done locally,

    and WINCP is asking for a private keyfile, where do I get that from??

    need to logon as [email protected] but dont know how to do it using ftp.
     

    Attached Files:

    • ftp.jpg
      ftp.jpg
      File size:
      60.2 KB
      Views:
      174
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you selcetd to connect with scp and use the same password that you use to login as root with putty.
     
  7. allenmally8

    allenmally8 New Member

    Think im blonde lol changed it to scp and still get access denied
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    And you are able to login with the same credentials (root username and password) with putty???
     
  9. allenmally8

    allenmally8 New Member

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    ok. this means that you can not login as root user as you login as mally and not root. you have to enable root logins in the sshd_config file.
     
  11. allenmally8

    allenmally8 New Member

    and how do I do that?
     
  12. allenmally8

    allenmally8 New Member

    and how do I enable root logins?
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Open /etc/ssh/sshd_config and make sure you have
    Code:
    PermitRootLogin yes
    in it. Then restart SSHD:
    Code:
    /etc/init.d/ssh restart
     
    Appie Thrasher likes this.
  14. allenmally8

    allenmally8 New Member

    Hi Falko just had a look at the file and it all ready got PermitRootLogin set to yes, dont know if you got any other ideas as I got none lol.

    and big thanks to Till who tried to help me yesterday.
     
  15. giftsnake

    giftsnake New Member

    if you have installed rkhunter, it might prohibit ssh with user root.
     

Share This Page