ftp filezilla root good user ng

Discussion in 'Server Operation' started by steve I, Nov 6, 2019.

  1. steve I

    steve I New Member

    I cant figure this out. I created filezilla account for root sftp and login is perfect.
    Now I created a user with (no Prefix) and copied the root config for filezilla but changed the password to user password. Filezilla says connection refused.
    Why is it doing that?
     
  2. Steini86

    Steini86 Active Member

    Have you created an ssh user? sftp needs an ssh user, while ftp(s) needs an ftp user.
     
  3. steve I

    steve I New Member

    ok. I did not create a ssh user. Created shell user...not real obvious. That needs to be changed to ssh user and not shell user.
    but I tried ftp with ftp user and that did not work either
     
    Last edited: Nov 7, 2019
  4. Steini86

    Steini86 Active Member

    Well, I meant shell user. They are just able to login via ssh ;)
    With such a detailed error message, nobody will be able to help you, sorry.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you create a shell user? Are you using ISPConfig, in that case take care that you create a non-jailed shell user if you want to use it for sftp.
     
  6. steve I

    steve I New Member

    Shell user worked fine.
    But plain old ftp user was created without prefix. Filezilla gives me error connection refused.
     

    Attached Files:

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Latest FileZilla versions try to enforce TLS 1.3 even if the server does not support it, which makes the FTP connection fail. Try a different FTP client or an older FileZilla version or try to fid a newer pure-ftpd-mysql package for your Linux distribution.
     
  8. steve I

    steve I New Member

    I currently have no version of pure ftpd that i am aware of.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Which tutoirial did you use to install your server? Do you use any control panel to manage it? pure-ftpd is the FTP server software sued by all ISPConfig systems, so if you have not installed it, then you must run a different control panel than ISPConfig.
     
  10. steve I

    steve I New Member

  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  12. steve I

    steve I New Member

    Yes. the howto version assumes that your server located where you are. In depth explaination about local networks etc. No many users will need all of that extra information. His version worked well except for the pureftpd. Not sure why, but when I go to install pureftpd from shell, it get a message that says no package pure ftpd available. Nothing to do
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ahrasis likes this.
  14. steve I

    steve I New Member

    Part of the how to involves setting up your video card. In my world that means the server is in the same room.
     
  15. ahrasis

    ahrasis Well-Known Member

    You assumed too much. Perfect server tutorials usually work perfectly. If you insist on following tutorials other than the one on howtoforge.com, you should be asking its writer there, not here.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    The perfect server tutorial does not contain any instructions to setup or configure a video card and all perfect server tutorials are written by using headless remote servers in a data center.

    Back to your problem, the rose hosting guide is very incomplete, you can not get a fully working setup when you use it. Reinstall your server by using the official guide or at least redo each step of the official guide to install all the missing parts and then run an ispconfig update with reconfigure services.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Just for your info, I've just left this comment on the rosehosting site after a quick review of their instructions. Their guide is a complete failure, about 50% of the nescessary steps are missing.

     

Share This Page