ftp failed to retrieve directory

Discussion in 'Installation/Configuration' started by ariban99, Feb 2, 2017.

  1. ariban99

    ariban99 Member

    I set up an ftp user in ispconfig 3.1 p1, however locally it works like a charm but remotely it gets stuck at failed to retrieve directory.
    i opened port 21 to the server.
    is there another port or something else to open to make it work remotely?
  2. webguyz

    webguyz Active Member HowtoForge Supporter

    If behind a firewall you probably need to add PASV or passive ports. Google these and then add PASSIVE option to pure-ftp. You will need to add the passive ports to your fw as well.
  3. ariban99

    ariban99 Member

    thank you.
    if anyone running centos 7 needs the solution here it is: (plus forward the same below port range in your firewall as well)
    How to enable passive ports on your pure-ftpd server and CSF Firewall
    When transferring files on/from your ftp server you will need to have passive ports specified and allowed in the firewall.

    Firstly lets edit pure-ftpd configuration file

    nano /etc/pure-ftpd/pure-ftpd.conf
    Uncomment (remove # at beginning of the line) PassivePortRange and specify the passive port range:

    PassivePortRange 35000 50000
    Restart pure-ftpd to load the new configuration

    service pure-ftpd restart

Share This Page