FTP Error: 550 Cant change directory to /: Permission denied

Discussion in 'Installation/Configuration' started by amdp, Oct 29, 2013.

  1. amdp

    amdp New Member

    Hello,

    I installed ispconfig3 and my ftp users have this kind of problem:

    FTP Error: 550 Cant change directory to /: Permission denied

    what should be the trick?

    Thanks
     
  2. amdp

    amdp New Member

    I don't understand if it is a chroot problem because it looks for "/" or just a permission one.
     
  3. amdp

    amdp New Member

    Ok.
    I read both PureFTP documentation and ISPConfig one.
    I installed everything starting from Perfect Apache2, Centos 6, Ispconfig3, etc etc, version 2013
    I ftp'd with the username and password created on IspConfig3 and it works, but
    229 Extended Passive mode OK (|||3546|)
    150 Accepted data connection
    226-Sorry, we were unable to read [.]

    I searched the mysql/phpmyadmin database for user name and password, and still no problem there.
    I studied pureftp and how it works with mysql, and no trouble there either.
    The folders are there, users are the right ones, the group could be "clientx" and the user "webx".

    So what?

    What should I do to have a ftp connection now seems only to uninstall ispconfig and go back to standard server administration, which actually worked quite fine till now.
     
  4. amdp

    amdp New Member

    UPDATE

    I edited /etc/my.cnf adding the line:

    log=/var/log/mylog.log

    and then

    touch /var/log/mylog.log

    and then

    chown mysql:mysql /var/log/mylog.log

    and started viewing the log: nothing was irregular.

    Then I decided to make a test. I made a /var/www/testftp folder with permissions web7:client0 and tried to access it through ftp. It worked quite fine so that now I know:

    1. The PureFtpd works pretty fine
    2. The mysql ispconfig database as well
    3. The username and password of the virtual user created by ispconfig into pureftpd work
    4. The correlation between username and password and the user web7 and the group client0 does work.

    The problem so far then sticks to the /var/www/client/client[any n, in this case 0]/web7.
     
  5. amdp

    amdp New Member

    If I edit the pureftpd configuration file and set not to cage the users [chroot option] I have access to the directory. Finding a way to fix that one also.
     

Share This Page