FTP doesn´t work

Discussion in 'Installation/Configuration' started by erkan, May 9, 2012.

  1. erkan

    erkan New Member

    Hi

    I have just now installed ISPConfig and ProFTPD. I have created a site and an FTP account in the ISPConfig control panel but when I try to login to the FTP account using my FTP client it just says "login incorrect".

    Does someone know what I can do to find out what is wrong?
     
  2. till

    till Super Moderator

  3. erkan

    erkan New Member

    Ok, I tried PureFTPD first but couldn´t get that to work but I will try again.
     
  4. till

    till Super Moderator

    Which tutoriald did you use to prepare your server for the installation of ispconfig and is this a virtual server?
     
  5. erkan

    erkan New Member

  6. till

    till Super Moderator

    The guide from linode seems to be quite incomplete, many required packages and settings are missing.

    I recommend to uninstall ispconfig with the uninstall.php script from the ispconfig tar.gz, then redo all steps from the official ispconfig tutorial starting with step 8:

    http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3-p3

    The pure-fpd package from Debian does not work on openvz by default as capabilities in openvz are disbaled. To install it, use this guide form ispconfig faq:

    http://www.faqforge.com/linux/contr...irtual-machines-without-capabilities-enabled/

    do this right after you finished step 13 of the perfect server guide.
     
  7. erkan

    erkan New Member

    Ok thanks! I will try that and get back to you when I have the result!
     
  8. erkan

    erkan New Member

    Yes it worked! Thank you so very much!
     
  9. erkan

    erkan New Member

    Ok now I got problems again.

    When I follow this guide: http://www.faqforge.com/linux/contr...irtual-machines-without-capabilities-enabled/

    It seems that I have downloaded a newer version of pureftpd so the file names in the commands is wrong for me.

    So far I have figured out that the version I have downloaded is 1.0.28. So I thought that I just change the commands. But there is one command that doesn´t work when I change it, this:

    dpkg -i pure-ftpd-common_1.0.21-11.4_all.deb pure-ftpd-mysql_1.0.21-11.4_i386.deb

    I tried to change it to:

    dpkg -i pure-ftpd-common_1.0.28-11.4_all.deb pure-ftpd-mysql_1.0.28-11.4_i386.deb

    But that didn´t work, I guess the -11.4 is supposd to be something else for my version but I don´t know what to change it to?
     
  10. till

    till Super Moderator

    Run:

    ls -la

    command in the direcotory after you compiled pure-ftpd and then install the .deb files that start with pure-ftpd-common and pure-ftpd-mysql that you find there.
     
  11. erkan

    erkan New Member

    Ok I am new a this so I think I need more explanation because I can´t get it to work. All I get is "command not found".
     
  12. till

    till Super Moderator

    The ls command is part of any linux shell, so it must be there. Execute this exact command:

    ls -la

    and post the output.
     
  13. erkan

    erkan New Member

    Now it worked, this it the output:

    total 104
    drwxr-xr-x 10 root root 4096 Oct 26 2010 .
    drwxr-xr-x 20 root root 4096 May 11 16:21 ..
    drwxr-xr-x 2 root root 36864 May 11 16:42 bin
    drwxr-xr-x 2 root root 4096 Feb 8 2011 games
    drwxr-xr-x 43 root root 4096 May 11 16:42 include
    drwxr-xr-x 55 root root 20480 May 11 16:42 lib
    lrwxrwxrwx 1 root root 3 May 11 16:20 lib64 -> lib
    drwxrwsr-x 10 root staff 4096 Jul 8 2010 local
    drwxr-xr-x 2 root root 12288 May 11 16:37 sbin
    drwxr-xr-x 100 root root 4096 May 11 16:42 share
    drwxrwsr-x 3 root dip 4096 May 11 16:41 src
     
  14. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /usr/src/pure-ftpd/
    ?
     
  15. erkan

    erkan New Member

    This is the output:

    total 1400
    drwxr-sr-x 3 root dip 4096 May 11 16:51 .
    drwxrwsr-x 3 root dip 4096 May 11 16:41 ..
    drwxr-xr-x 11 root root 4096 May 11 16:51 pure-ftpd-1.0.28
    -rw-r--r-- 1 root dip 180678 May 11 16:51 pure-ftpd-common_1.0.28-3+squeeze1_all.deb
    -rw-r--r-- 1 root dip 139310 May 11 16:51 pure-ftpd-ldap_1.0.28-3+squeeze1_amd64.deb
    -rw-r--r-- 1 root dip 153432 May 11 16:51 pure-ftpd-mysql_1.0.28-3+squeeze1_amd64.deb
    -rw-r--r-- 1 root dip 140206 May 11 16:51 pure-ftpd-postgresql_1.0.28-3+squeeze1_amd64.deb
    -rw-r--r-- 1 root dip 47048 Jan 17 20:47 pure-ftpd_1.0.28-3+squeeze1.diff.gz
    -rw-r--r-- 1 root dip 1340 Jan 17 20:47 pure-ftpd_1.0.28-3+squeeze1.dsc
    -rw-r--r-- 1 root dip 2421 May 11 16:51 pure-ftpd_1.0.28-3+squeeze1_amd64.changes
    -rw-r--r-- 1 root dip 123596 May 11 16:51 pure-ftpd_1.0.28-3+squeeze1_amd64.deb
    -rw-r--r-- 1 root dip 605000 Feb 15 2010 pure-ftpd_1.0.28.orig.tar.gz
    -rw-r--r-- 1 root dip 98 May 11 16:44 rules
     
  16. falko

    falko Super Moderator

    You must run
    Code:
    dpkg -i pure-ftpd-common_1.0.28-3+squeeze1_all.deb pure-ftpd-mysql_1.0.28-3+squeeze1_amd64.deb
     
  17. erkan

    erkan New Member

    When it is about to install the second package I get this error message:

    invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
    dpkg: error processing pure-ftpd-mysql (--install):
    subprocess installed post-installation script returned error exit status 252
    Errors were encountered while processing:
    pure-ftpd-mysql
     

Share This Page