FTP doens't work

Discussion in 'Installation/Configuration' started by Solvik, Aug 11, 2007.

  1. Solvik

    Solvik New Member

    FTP doesn't work


    I recently installed ISPConfig, I think it's that I need.. But when I tryed to connect to the FTP, that didn't work.

    The FTP is actived on the plan.

    I created an user (administrator) web1_myname, with my password, when I try to log on, FileZilla give me that error: 530 Login incorrect.
    So the login doesn't work.

    Same things when I try to connect on http://IP:81/mailuser/ for example.
    > Erreur: Password error: Login failed.

    I don't understand.

    Thanks in advance for your help !

    Last edited: Aug 12, 2007
  2. edge

    edge Active Member Moderator

    Did you enable the Administrator option for that user?
    It's under ISP Manager > the-domain > User & Email > the_user_name. (you will need to enable the "Administrator" part.

    Also note that the login is the Username as shown in the User & Email part. (webNR_name)
  3. Solvik

    Solvik New Member

    Yes I did that. web1_solvik is administrator..
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    grep web1_solvik /etc/passwd
    Any errors in your logs? Which distribution do you use?
  5. Solvik

    Solvik New Member

    web1_solvik:x:10001:10001:Solvik BLUM:/home/www/web1:/bin/bash

    I use Debian 3.1

    Aug 11 13:12:46 localhost proftpd[16855]: - FTP session opened.
    Aug 11 13:12:48 localhost proftpd[16855]: - PAM(web1_solvik): Authentication failure.
    Aug 11 13:12:48 localhost proftpd[16855]: - FTP session closed.
  6. Solvik

    Solvik New Member

    When I try to use web-ftp, it says an error:

    Impossible to connect with web1_solvik

    (translation of my french error message :))
  7. hendry

    hendry New Member

    Do you have your servername right in your hosts file?
  8. Solvik

    Solvik New Member

    ~# cat /etc/hostname

    thats is the problem ? Do I need to change that ? :s

    EDIT: modified, that's work :)
    Last edited: Aug 12, 2007
  9. falko

    falko Super Moderator ISPConfig Developer

    Are you absolutely sure you're using the correct password? Please set a new one in ISPConfig and try again.
  10. jsalihi

    jsalihi New Member

    I have the same problem:

    I use Debian Etch

    The user web2_joewan is administrator an the password is correct.

    ProFTPD Log:
    grep web2_joewan /etc/passwd
    But i can login to mailuser
  11. falko

    falko Super Moderator ISPConfig Developer

    You must enable FTP for that web site in ISPConfig. If users have /dev/null as shell, it means that FTP isn't enabled for that web site.

Share This Page