FTP - Connection refused using Certificate2

Discussion in 'Installation/Configuration' started by Wisdown, Sep 8, 2012.

  1. Wisdown

    Wisdown Member

    Hi guys,

    I was following the guide:

    http://www.howtoforge.com/securing-...h-a-free-class1-ssl-certificate-from-startssl

    And then i bought a certificate level2, i did an request for *.domain.com (then i dont need request more certificates) and the followed the guide.

    On apache worked pretty nice, i see the pages using https without warning messages, and clicking on certificate says startssl.

    On ftp, i got an problem, all connections says:

    Checking the /var/log/syslog i see this:

    Then my first guess is because the guide say to do an link, i did:

    Same error.
    Then my next guess is about the other file in same directory the: ssl-cert-snakeoil.key
    I tried copy ispserver.crt and named as ssl-cert-snakeoil.key, but dindt worked too..

    Someone can give me an hint how to fix it?

    I gonna check if the mails are working.
     
    Last edited: Sep 8, 2012
  2. Wisdown

    Wisdown Member

    I did more tests, my mail isnt working now, the logs say:

    But i have copied the files and they exist

    Checking on web, only the ISPConfig admin pannel get the certificate working, if i use:

    https://mydomain.com:8080

    The certificate works fine. But if i try:

    https://mydomain.com

    The page doesnt load.

    Other test i did is about roundcube redirect, when i try use another domain like:

    http://domain2.com/webmail

    Now the redirect isnt working anymore

    There another guide for get the certificate working without broken all those things?
     
  3. Wisdown

    Wisdown Member

    I fixed the issue with the ftp, from guide where says:

    Need be:

    Or gonna get the startssl.chain.class1.server.crt too, appending 3 files instead 2

    On mail server i did an full restart instead restart only the service, and mails are working now

    The issue about redirect for roundcube mail still, from other domain when i try:

    http://domain2.com/webmail

    The redirect is made for the old certificate.

    The last step i`m trying get working is have the SSL enabled for the main site, on ISPConfig Sites /Website/domain1 (my main domain) i checked the box SSL.
    But dindt worked.

    Apache Still saying:

    [warn] 192.168.100.3:443 has no VirtualHosts
     
    Last edited: Sep 9, 2012
  4. falko

    falko Super Moderator ISPConfig Developer

    You must go to the SSL tab and create an SSL cert.
     
  5. Wisdown

    Wisdown Member

    I solved the ssl issue follwing one hint yours in another post (dont have the link now since i`m opening a lot of tabs looking for research the solutions).

    In the other post i see you saying to link the server certificate for the website folder(/ssl), i did same thing and worked pretty nice.
     

Share This Page