FTP connection from Internet

Discussion in 'Installation/Configuration' started by md mahbubur rahman, Jan 31, 2022.

  1. md mahbubur rahman

    md mahbubur rahman New Member HowtoForge Supporter

    Hi,
    I have installed ispconfig 3.2.7 where I have created user account, FTP account and website for the user. I can connect with FTP from my internal (LAN)network but I am not able to connect from internet (WAN side). I am using pfsense firewall. I have configured port forwarding to port 21. I am getting the following error:
    Server sent passive reply with unroutable address 10.2.150.180, using host address instead.
    Timeout detected. (data connection)
    Could not retrieve directory listing
    Error listing directory '/'.

    Please help. It would be highly appreciated
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

  3. md mahbubur rahman

    md mahbubur rahman New Member HowtoForge Supporter

    Hello Jesse,
    Thanks for your quick response. I followed the link but got the following result:
    upload_2022-2-1_12-15-35.png
     

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that the passive port range is still either not configured or blocked by a firewall on the server or by a firewall in front of the server (e.g. a Firewall of your ISP or the data center where you host the server).
     
  5. md mahbubur rahman

    md mahbubur rahman New Member HowtoForge Supporter

    Hi Till,
    Thanks for your reply. To test I have disabled firewall on ISPconfig. Allowed all inbound and outbound traffic for passive port range both on LAN and WAN interface. I have also attached the screenshot of port forwarding along with other screenshoots. But still it is not working. I do not know where I am going wrong
    please have a look. feel free to ask if it does not give any meaning to you
    upload_2022-2-1_14-12-36.png
    upload_2022-2-1_14-12-58.png upload_2022-2-1_14-13-8.png upload_2022-2-1_14-13-21.png
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You added a port forward for port 21 but not for the passive port range; those have to be forwarded to the server as well for the connection to succeed.
     
  7. md mahbubur rahman

    md mahbubur rahman New Member HowtoForge Supporter

    Thanks, I can do that. in that case which port shall I use in my FileZilla Client to initiate the FTP connection ?
     
  8. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Port 21, there's no reason to change that.
     
  9. md mahbubur rahman

    md mahbubur rahman New Member HowtoForge Supporter

    Thanks for your help. It is working now. But now I am not being able to connect from the LAN side with server's private IP address. I believe it is because the server is responding to the external address. Isn't there any way to get it worked both with Internally and Externally? I can use the public IP from LAN side, this way it is working. Fine. Have a great time. :)
     
    Last edited: Feb 1, 2022
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use the internal IP address in your FTP client connection settings. This might produce a SSL warning though.
     
  11. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Pfsense is pretty configurable, I imagine you could also get it to hairpin connections to the public ip back to that server. Personally I would just use SFTP, which is much simpler.
     

Share This Page