FTP connect errors (after many hours of research)

Discussion in 'ISPConfig 3 Priority Support' started by peterpetr, Dec 2, 2016.

  1. peterpetr

    peterpetr New Member HowtoForge Supporter

    Hello, I spend many hours researching and testing before posting this request. I have ISPconfig 3.1.x installed using: https://www.howtoforge.com/tutorial/perfect-server-ubuntu-with-nginx-and-ispconfig-3/
    The Perfect Server - Ubuntu 15.10 (nginx, MySQL, PHP, Postfix, BIND, Dovecot, Pure-FTPD and ISPConfig 3). But my server is Ubuntu 14.x. Using Filezilla (latest version on Windows 10), disabled firewall.
    On my ISPconfig, setup the passive ports (firewall & pure-ftp) per your instructions found elsewhere. I do want an encrypted FTP connection. Tested at https://ftptest.net with the following output:

    Status: Resolving address of ***.***.com
    Status: Connecting to 209.**.**.**
    Warning: The entered address does not resolve to an IPv6 address.
    Status: Connected, waiting for welcome message...
    Reply: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Reply: 220-You are user number 1 of 50 allowed.
    Reply: 220-Local time is now 01:23. Server port: 21.
    Reply: 220-This is a private system - No anonymous login
    Reply: 220-IPv6 connections are also welcome on this server.
    Reply: 220 You will be disconnected after 15 minutes of inactivity.
    Command: CLNT https://ftptest.net on behalf of 50.**.**.**
    Reply: 530 You aren't logged in
    Command: AUTH TLS
    Reply: 234 AUTH TLS OK.
    Status: Performing TLS handshake...
    Status: TLS handshake successful, verifying certificate...
    Status: Received 1 certificates from server. *** cert info deleted ***
    Command: USER username*
    Reply: 331 User username* OK. Password required
    Command: PASS ****************
    Error: Connection timed out
    I am using a correct password. It includes the prefix. I tried with several accounts with FTP client settings: port: 21, Protocol: Explicit FTP over TLS, both passive and default settings in FileZilla. I also tried on two different networks, 2nd network with no hardware (router/modem) was on my cellular connected laptop.
    Your expertise and advice would be very much appreciated to resolve this FTP connection problem.
    Thank you.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    When the server is behind a router, then you can try to set ForcePassiveIP as well, set it to the external IP of the router.
     

Share This Page