FTP authentication issues

Discussion in 'General' started by Sharone, Jul 27, 2020.

  1. Sharone

    Sharone Member

    Hi,
    I am having trouble with the web server on a multiserver setup. I set up an FTP account but cannot authenticate using Filezilla or via cli. The logs reveal an authentication error, username i use is "userftp" as it appears on the ISPConfig portal. Port 21 is open & listening

    Filezilla
    Code:
    Command:    USER userftp
    Response:    331 User userftp OK. Password required
    Command:    PASS ***********
    Response:    530 Login authentication failed
    Error:    Critical error: Could not connect to server
    auth.log
    Code:
    Jul 27 16:48:00 web-20 sshd[22776]: Invalid user userftp from 10.0.0.3 port 26912
    Jul 27 16:48:02 web-20 sshd[22776]: Failed password for invalid user userftp from 10.0.0.3 port 26912 ssh2
    Jul 27 16:48:02 web-20 sshd[22776]: Connection closed by invalid user userftp 10.0.0.3 port 26912 [preauth]
    
    
    syslog
    Code:
    Jul 27 18:40:43 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 19:11:03 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 19:34:21 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 19:38:35 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 19:41:42 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 19:50:54 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 19:51:00 web-20 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [userftp]
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    check the ftp_user table on the salve system if it contains that user.
     
  3. Sharone

    Sharone Member

    Yes the user exists in the ftp_user table on the slave server. Passwords are the same too
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a Debian or Ubuntu system? if yes, check that you have the pure-ftpd-mysql package installed and not just pure-ftpd. And check that you have no shell user with the username 'userftp' in /etc/passwd
     
  5. Sharone

    Sharone Member

    I'm using Ubuntu 18.04. I tried to install pure-ftpd-mysql earlier but got this error
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. Sharone

    Sharone Member

    I've managed to install it thanks and followed the subsequent guidelines. However still getting the same errors in the logs.
     
  8. Sharone

    Sharone Member

    Here's what I get now even though I am able to login to the mysql db

    Code:
    [email protected]:~# service pure-ftpd-mysql status
    ● pure-ftpd-mysql.service
       Loaded: loaded (/etc/init.d/pure-ftpd-mysql; generated)
       Active: active (running) since Mon 2020-07-27 23:37:47 EAT; 38s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 26888 ExecStop=/etc/init.d/pure-ftpd-mysql stop (code=exited, status=0/SUCCESS)
      Process: 26898 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status=0/SUCCESS)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/pure-ftpd-mysql.service
               └─26907 pure-ftpd (SERVER)
    
    Jul 27 23:37:46 web-20 systemd[1]: Starting pure-ftpd-mysql.service...
    Jul 27 23:37:47 web-20 pure-ftpd-mysql[26898]: Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 100
    Jul 27 23:37:47 web-20 systemd[1]: Started pure-ftpd-mysql.service.
    Jul 27 23:38:15 web-20 pure-ftpd[26948]: ([email protected]) [INFO] New connection from 10.0.0.3
    Jul 27 23:38:16 web-20 pure-ftpd[26948]: ([email protected]) [INFO] TLS: Enabled TLSv1.3 with TLS_AES_256_GCM_SHA384, 256 secret bits cipher
    Jul 27 23:38:16 web-20 pure-ftpd[26948]: ([email protected]) [ERROR] The SQL server seems to be down [Access denied for user 'root'@'localhost' (using password: YES)]
    Jul 27 23:38:16 web-20 pure-ftpd[26948]: pam_unix(pure-ftpd:auth): check pass; user unknown
    Jul 27 23:38:16 web-20 pure-ftpd[26948]: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser=userftp rhost=
    Jul 27 23:38:23 web-20 pure-ftpd[26948]: ([email protected]) [WARNING] Authentication failed for user [userftp]
    Jul 27 23:38:23 web-20 pure-ftpd[26948]: ([email protected]) [INFO] Logout.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you run the ispconfig installer again with reconfigure services = yes on that node? If not, please do that.
     
  10. Sharone

    Sharone Member

    This worked. I can't thank you enough.
     

Share This Page