ftp authentication fails

Discussion in 'Installation/Configuration' started by fooboo, Mar 17, 2010.

  1. till

    till Super Moderator

    Maybe you entered a wrong mysql server as you installed ispconfig? The mysql server must be "localhost" as the installer suggest you and not "127.0.0.1" as this causes plroblems with mysql logins, the mysql daemon is not able to determine that 127.0.0.1 and localhost are the same.
     
  2. fooboo

    fooboo New Member

    I've given ispconfig access via 127.0.0.1 and localhost and it was working fine before for months after the initial setup but I still have a problem with ispconfig thinking MySQL isn't running.
     
  3. fooboo

    fooboo New Member

    Is fetchmail affected by SASL settings? I've just noticed my SASL setup needs tweaking, I'm getting error messages.
     
  4. falko

    falko Super Moderator

    Can you post the error messages?
     
  5. fooboo

    fooboo New Member

    It prints these in the log every so often:

    postfix/smtpd[4784]: warning: SASL: Connect to private/auth failed: No such file or directory
    postfix/smtpd[4784]: fatal: no SASL authentication mechanisms
    postfix/master[2495]: warning: process /usr/libexec/postfix/smtpd pid 4784 exit status 1
    postfix/master[2495]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
     
  6. falko

    falko Super Moderator

  7. fooboo

    fooboo New Member

    Which comment is it?

    Code:
    
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 amavis
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 anvil
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 bounce
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 bsmtp
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 cyrus
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 defer
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 discard
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 dovecot
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 error
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 ifmail
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 lmtp
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 local
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 maildrop
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 old-cyrus
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 proxymap
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 relay
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 rewrite
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 scache
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 smtp
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 tlsmgr
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 trace
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 uucp
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 verify
    srw-rw-rw-  1 postfix postfix    0 Mar 23 02:21 virtual
    
    
     
  8. fooboo

    fooboo New Member

    I've managed to clear up most of the error messages by going through the various conf files and changing 127.0.0.1 to localhost wherever a MySQL connection is used which is a bit of a kludge as if I ever update any of the software I'll have to do that again but I still have problems with software trying to connect to MySQL on 127.0.0.1 and it failing.

    I turned off iptables to see if it was a rule stopping this from working but that didn't sort it.

    I ran:

    Code:
    GRANT ALL PRIVILEGES ON *.*
      TO 'root'@'%'
      IDENTIFIED BY '<my_password>'
      WITH GRANT OPTION;
    
    to see if resetting the privileges would help but it didn't

    Whenever anything tries to connect to MySQL on 127.0.0.1 I get:

    Code:
    ERROR 2003 (HY000): Can't connect to MySQL server on '127.0.0.1' (111)
    It's really frustrating as I know even if I find every reference on my entire system to 127.0.0.1 and change it to localhost all I have to do is update a package that rewrites a conf somewhere and I'm back to this state.
     
  9. fooboo

    fooboo New Member

    I've just checked some of the settings on another machine on which I can access mysql via 127.0.0.1
    When I run netstat -p I get:

    Code:
    tcp        0      0 *:mysql                     *:*                         LISTEN      22654/mysqld
    
    But on my machine I get:

    Code:
    tcp        0      0 <my_domain>:mysql      *:*                         LISTEN      5353/mysqld
    
    Does anyone know where I go to change the above setting?
    I was wondering if it's listening on my domain instead of for all connections?
     
  10. falko

    falko Super Moderator

    On Debian/Ubuntu, you can change it in /etc/mysql/my.cnf. On other distributions it's most likely /etc/my.cnf.
     
  11. fooboo

    fooboo New Member

    What setting is it? I don't have an entry in my.cnf with my domain or an *

    Code:
    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    user=mysql
    max_allowed_packet=100000000M
    bind-address = <my_ip>
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1
    
    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    
     
  12. fooboo

    fooboo New Member

    LOL just posting my my.cnf on here I noticed something, tried it out and it worked. I switch the bind address from my IP to 127.0.0.1
    Man I wish I knew what I was doing...I could have tried that ages ago :D
     
  13. fooboo

    fooboo New Member

    I've lost my remote access now though...hmm!
     
  14. fooboo

    fooboo New Member

    Do you know if you can use more than one bind address?
     
  15. fooboo

    fooboo New Member

    I'm on a roll. If you remove the 'bind-address" line altogether it works for both 127.0.0.1 and remote access.
     

Share This Page