FTP and Web sites in ISPConfig

Discussion in 'Installation/Configuration' started by erothoff, May 19, 2008.

  1. erothoff

    erothoff New Member

    I have just installed ISPConfig on a new server. (Ubuntu 8.04 LTS using Perfect Server HowTo and ISPConfig guide) I can get in, set up new users and resellers. I can not ftp into the server though. (Neither through ISPConfig nor just ftp.) When I stop and start ProFTPD I get:

    root@host:~/install_ispconfig# /etc/init.d/proftpd stop
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    * Stopping ftp server proftpd [ OK ]
    root@host:~/install_ispconfig# /etc/init.d/proftpd start
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    * Starting ftp server proftpd - warning: handling possibly truncated configuration data at line 179 of '/etc/proftpd/proftpd.conf'
    - setting default address to 127.0.0.1


    Line 180 is an include line, and 179 is commented out. I have been working on it all day but to no avail. Any suggestions on how to track down the problem. I am sure it is simple if I know where to look.
    Thanks in advance...
    Eric
     
  2. erothoff

    erothoff New Member

  3. catdude

    catdude ISPConfig Developer

    Is user "rothoff" defined as an Administrator? If so, making an FTP connection as that user should take you to the document root directory for the domain. If that user is not defined as an admin an FTP connection will take you just to the the user's personal web directory.
     
  4. erothoff

    erothoff New Member

    Almost...

    The problem with the "rothoff" login isn't that it goes to the wrong directory, but I can't log in at all with that login.

    But adding admin rights to a client's users/email did allow me to get in and update the web site. Which is what I needed.

    I'll try to find out the reasons whey admin, resellers and clients can't log into the server for FTP, even though they have FTP access.

    As I always say: "Get things working first, THEN improve them." I got it working now...
    Thanks
     

Share This Page