Ftp and Swedish characters in Directory field

Discussion in 'General' started by damir, Oct 28, 2011.

  1. damir

    damir New Member

    Hi all,

    This issues came up after moving to new server. Everything is identical besides hardware. OS Debian 6.0.3

    I have a issue regarding FTP part in ISPConfig 3. I have created new FTP user and i have changed the path i Directory field to a folder inside user webspace. Problem is that created folder contains swedish characters.

    Code:
    /var/www/clients/client1/web1/webdav/ftp/testing/skåne
    With this path i get error connect with Filezilla:

    Code:
    Home directory doesn't exist. Abort.
    If i remove skåne part than it connects correct. In dbispconfig database path looks correct. Could it be that Pureftpd doesn't translate "skåne" part correctly.

    Any thoughts?
     
  2. till

    till Super Moderator

    That can be the case. ISPConfig supports all foreign characters as it uses UTF-8, but this does not mean that all other software are able to use the paths in their configuration even if they are correctly stored in mysql. Have you tried to enable debugging in pure-ftpd and check the log for errors then?
     
  3. damir

    damir New Member

    Hi Till and thank for reply.

    I enabled verbose logging and this is the error i receive while i try to connect to folder that contains swedish char Å:

    Code:
    Oct 28 15:15:53 test pure-ftpd: (?@10.0.0.30) [ERROR] Home directory not available - aborting
     
  4. falko

    falko Super Moderator

    I highly recommend not to use any special characters in paths, usernames, etc.
     
  5. damir

    damir New Member

    I'm aware of that :) The thing is it worked well on Lenny but not on Squeeze and my client is hangedup on the, it worked before.
     
  6. till

    till Super Moderator

    Which Linux charset did you use on Lenny and which charset do you use on Squeeze now?
     
  7. damir

    damir New Member

    I have used "sv_SE.UTF-8" as default on both.

    If i remove "skåne" from Directory path in ISPConfig and add "skåne" to remote path in Filezilla instead, than it connects without problems.

    Only when i want to lock user to folder "skåne" and adding that to Directory path in ISPConfig that i cannot connect. I recive: "421: Home directory not available - aborting"

    If i can connect to "skåne" folder when adding it to Filezilla's remote path than Pure-ftpd understands "å" character?
     

Share This Page