FTP and ISPConfig

Discussion in 'Installation/Configuration' started by rlhesson, Aug 6, 2006.

  1. rlhesson

    rlhesson Guest

    Ok I have ISPConfig working so it sets up a new directory in /var/www for new clients. However, when it sets up the FTP account with proftp it sets their ftp account to /home/username and they are locked there and cant ftp to their site. How do i correct this?

  2. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig creates users with /home/... as homedir while web sites are created in /var/www? I can hardly believe that. What's in /etc/passwd?
  3. rlhesson

    rlhesson Guest

    When I click on create a new client then Create a new Site in ISPConfig it makes a folder in /var/www/web(clientnumber) so for this example we will use /var/www/web1. Ok when it creates an FTP account for that user it creates that account with their home directory being /home/username. When you login with that account they are locked into /home/username. I dont have an /etc/passwd file. Any ideas?
    Last edited by a moderator: Aug 8, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig never creates users with the home directory /home/username, that can not happen if you did not change the sourcecode.

    Wich authentication mechanism do you use if you dont have an /etc/passwd file? LDAP?
  5. rlhesson

    rlhesson Guest

    Well what program defaults users to /home/username/ when they FTP? Would that be proftp doing that? Im new to linux but something is making it so that when users login to their ftp account using winscp they login in to /home/username. Im sorry here is my /etc/passwd file I did not see it before:

    rpm:x:13:101:system user for rpm:/var/lib/rpm:/bin/false
    vcsa:x:69:69:virtual console memory owner:/dev:/sbin/nologin
    xfs:x:70:70:system user for xorg-x11:/etc/X11/fs:/bin/false
    messagebus:x:71:71:system user for dbus:/:/sbin/nologin
    haldaemon:x:72:72:system user for hal:/:/sbin/nologin
    rpc:x:73:73:system user for portmap:/:/bin/false
    apache:x:74:74:system user for apache:/var/www:/bin/sh
    rpcuser:x:75:75:system user for nfs-utils:/var/lib/nfs:/bin/false
    postfix:x:76:76:system user for postfix:/var/spool/postfix:/bin/false
    sshd:x:77:77:system user for openssh:/var/empty:/bin/true
    rlhesson:x:500:500:Web Master:/home/rlhesson:/bin/bash
    ntp:x:78:78:system user for ntp:/etc/ntp:/bin/false
    named:x:79:79:system user for bind:/var/named:/bin/false
    mysql:x:80:423:system user for MySQL:/var/lib/mysql:/bin/bash
    ftp:x:81:424:system user for proftpd:/var/ftp:/bin/false
    admispconfig:x:501:501:Administrator ISPConfig:/home/admispconfig:/bin/bash
  6. rlhesson

    rlhesson Guest

    Oh I see now by looking at that /etc/passwd file. If you login using your username the way that ISPConfig creates it you login to the correct directory. I was loggin in using the username / password I created upon installing linux. Is there anyway for me to change the director that rlhesson goes to? If you look in that file I posted above he goes to /home/rlhesson
  7. falko

    falko Super Moderator ISPConfig Developer

    You can edit /etc/passwd with a text editor like vi: http://www.howtoforge.com/faq/12_15_en.html

    WinSCP uses SSH on port 22 whereas FTP is on port 21. WinSCP has nothing to do with FTP (though it looks similar).
  8. rlhesson

    rlhesson Guest

    Ah ok. Thanks for helping me through this issue!
  9. phoenixtechnical

    phoenixtechnical New Member

    PureFTP won't work with ISPConfig FTP user

    I just setup ISPConfig and added my first website domain.
    I added an FTP user, but when I tried to ftp in, the ftp connection rejected the username
    and password. I tried it a few times, it definitely does not work (for me).

    The PureFTPd server does allow normal FTP connections for people who have linux user accounts on the machine. The machine is running Ubuntu.

    Does anyone know what is causing this?


  10. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig 2 doesn't support PureFTPd, only ProFTPd and vsftpd. If you're using ISPconfig 3, then you've posted in the wrong forum. ;)
  11. jolierouge

    jolierouge New Member

    User passwords are not as expected

    Hey All,

    I have a similar problem in that the user's are created, but the password is not correct.

    I cannot log into ftp or webmail with the username and password combo, I cannot login via ssh/shell account either.

    However, I can su, and there is an entry in /etc/shadow for the user, and there is a password hashed, it's just not the one I chose.

    Using root, I can change the password of the user to the correct one and voila, ftp, webmail and shell now work fine.

    I may have misstyped the password on creation, however I went back to the user edit page and was very careful to enter the password again...

    Perhaps this is normal, and it is not really an inconvenience to have to change passwords manually, I only have a few customers, so it takes not even 5 minutes.

    Any help on making that a bit more automatic would be awesome.
  12. falko

    falko Super Moderator ISPConfig Developer

    Are there any warnings in /home/admispconfig/ispconfig/ispconfig.log?

Share This Page