FTP access?

Discussion in 'Installation/Configuration' started by ctroyp, Sep 29, 2005.

  1. ctroyp

    ctroyp HowtoForge Supporter

    I can successfully access my ftp site for one of my sites but not another. The first site I access is ftp://ftp.domain1.com and everything is fine, but the other, ftp://ftp.doamin2.com I can login to but it doesn't show any directories. Any idea what what the problem could be? Both sites accept the respective login credentials but only the first one displays my website directories.

    Another thing, I can only access the ftp sites from outside of my server. When I try at my server, I get and alert dialog, "530 login incorrect" for site one and, "ftp.domain2.com could not be found. Please check the name and try again.".

    I do have ftp access checked for each site in the admin control panel.
     
  2. till

    till Super Moderator

    Are you shure you checked the "Administrator" checkbox for the admin user of domain2?
     
  3. falko

    falko Super Moderator

    Do the nameservers your server uses resolve ftp.domain2.com correctly?

    Did you try Passive Transfers in your FTP client for both accounts? Might be a firewall issue.
     
  4. ctroyp

    ctroyp HowtoForge Supporter

    Where would I find that checkbox? Is it under the client settings or site management? I didn't have any luck finding it...
     
  5. till

    till Super Moderator

    In the settings of the user.
     
  6. ctroyp

    ctroyp HowtoForge Supporter

    I will check on that to see. I think that may be the problem. Last night I setup SSH/PuTTY to connect to my server while away for this very reason--to check settings. SSH is working, but only in the terminal. Only because I ama newbie to the linux environment, is there a GUI that will show me the desktop so I could navigate in that manor? Something like remote control or terminal services?

    Where do I set the "Passive Transfers"? Last night I found that I didn't have ftp aliased for domain2.com. After I assigned the alias I could login and see the directories, but they we the wrong ones--the index.html, for instance was the ISPConfig default instead of the one I created for this site.

    I have a router firewall enabled, the Fedora firewall enabled, and the firewall installed in your "The Perfect Setup".
     
  7. ctroyp

    ctroyp HowtoForge Supporter

    When I try to check the administrator box and click save, I get:
    Code:
    Field: WebSpeicher MB
    Es sind nur Zahlen erlaubt.
    
    Field: WebSpeicher MB
    Es sind nur Zahlen erlaubt.
    Only numbers are allowed? In what, I checked a checkbox?
     
  8. falko

    falko Super Moderator

    Please have a look here: http://www.howtoforge.com/forums/showthread.php?t=596

    TightVNC: http://www.tightvnc.com/

    Code:
    Where do I set the "Passive Transfers"?
    If you use WS_FTP as ftp client, then it's on the Advanced tab.
     
  9. ctroyp

    ctroyp HowtoForge Supporter

    Actually, I figured it out just before you replied...thanks.

    Thanks for the reference.

    I am unsure that I have WS_FTP. If it wasn't installed during your setup, then I probably don't.
     
  10. till

    till Super Moderator

    WS_FTP is a windows FTP client.
     
  11. ctroyp

    ctroyp HowtoForge Supporter

    Installing it now...thanks!
     
  12. ctroyp

    ctroyp HowtoForge Supporter

    I still cannot access ftp://ftp.domain2.com. I have set the user to administrator. When I enter this address into my browser, it doesn't even prompt for a username, it just displays:
    Code:
    Windows cannot ccess this folder.  Make sure you typed the file name correctly and that you have permission to access this folder.  
    
    Details:
    220 wf9.dnsvr.com FTP Server (Version 6.00LS) ready.
    530 User anonymous unknown. 
    FYI, I am not allowinf anonymous logon.

    When I use WS_FTP, I can enter the username and password and it is rejected. I noticed in the connection details, it has a different WAN IP as the public IP on my router. Also, remember, I do have another site that I can successfully login to using these methods.

    Where is the path set for the respective website files in ISPConfig that are accessed via FTP?
     
  13. ctroyp

    ctroyp HowtoForge Supporter

    Now I can login to the user Web-FTP within ISPConfig and it shows the appropriate files, but still cannot login using the same credentials from browser or WS_FTP???

    ...getting closer.
     
  14. ctroyp

    ctroyp HowtoForge Supporter

    I just ran a few trace routes and found that my second site is not being routed appropriately from zoneedit.com. I will take a look and see what is going on. This should fix my problem.

    Thanks for being patient with me... :rolleyes:
     
  15. ctroyp

    ctroyp HowtoForge Supporter

    Got it all working. Turns out, zoneedit had routed my domain innacurately.

    Thanks again...
     

Share This Page