FTP access

Discussion in 'Installation/Configuration' started by pineapple, Aug 15, 2010.

  1. pineapple

    pineapple New Member

    Okay - I've spent most of the day on this and am relenting and bothering you guys:

    I've installed ISPConfig2 on a new Linode and have is (mostly) configured. I followed the Perfect Server guide for Debian Lenny.

    My issue is that I can't for the life of me get an ISPConfig user to be able to FTP in. Normal Linux users are able to FTP and SSH but I can't do either with the users I have created in ISPConfig. I have had to remove the user prefix in this instance (in the past I have left the web[WEBID]_ and I am wondering if this is part of the problem? Usually I used the prefix with the username and that's the login. I'm assuming that when you remove the prefix then they login with just their single username but that's not working.

    I've re-installed and reconfigured proftp without any luck. The proftp log just shows a lot of opened and closed connections (which I'm assuming is all the authentication failures).

    Any ideas would be much appreciated.

    regards and thanks,

    Andrew
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you enable FTP for your web sites? When you say "ISPConfig user", what exactly do you mean with it? Is it a user that you created on the "User & Email" tab? This is a system user and should be able to use FTP. Usually, an ISPConfig user is a user that can log only into ISPConfig, e.g. a client or reseller.
     
  3. pineapple

    pineapple New Member

    Yes, the FTP checkbox is ticked for the site and by "ISPConfig User" I meant as you first suggest; a user created in ISPConfig in the Users & Email tab (as opposed to system user created in the shell). I probably should have said "website user".

    regards

    Andrew
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your logs? Did you try both active and passive transfers in your FTP client?
     
  5. pineapple

    pineapple New Member

    A simple re-start did the fix - it was as if the users created in ISPConfig were not recognised right away and only became active after restarting.

    Thanks for you help and patience.

    regards

    Andrew
     

Share This Page