ftp access is not possible from outside to ISPConfig Server

Discussion in 'General' started by surajlk, Jan 24, 2008.

  1. surajlk

    surajlk New Member

    Hi all
    I'm a new user to linux. however I managed to install Fedora 7 LAMP server with ISPConfig by using the Howtos short manual published in howtoforge.com. Everything installed and configured properly. no errors occured during the installation.

    With ISP config I created a site "officeinfo.lk.de" with the access of ftp. I created a user "web1_suraj" and assined him to the site.

    With the ISPconfig Web-FTP its working fine. I could upload documents and the site is working perfectly.

    The problem is when I connect from a different PC via ftp to this site (ftp://officeinfo.lk.de) the login information box apear which means the ftp connectivity is fine. But the same user "web1_suraj" which used in ISPconfig Web-FTP does not accept at this point. I used IE, Firefox even Microsoft FrontPage but it did not work.

    Can someone help me to solve this issue please?:confused:
    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap

    and

    iptables -L

    Did you try active and passive FTP?
     
  3. surajlk

    surajlk New Member

    Dear Till

    Thank you very much for your reply. I tried both active and passive ftp. no luck.
    please find the requested information.
    netstat:
    [​IMG]

    iptables:
    [​IMG]

    Do you think is there a problem with Proftpd. Because i saw something similar in forum. but in my case i could upload files via Web-FTP within ISPconfig perfectly.
     
  4. J4zen

    J4zen New Member

    Im actually having exactly the same problem, installed ISPConfig with ProFTPd. When i create a new site with any username/password combination it won't accept the credentials when i try to login.

    The installation was done according to the manual posted on this site for FC7(The perfect server), i tried reinstalling twice.

    The output of netstat -tap is:

    http://pastebin.ca/875743

    and iptables -L:

    http://pastebin.ca/875744

    Any input would be greatly apreciated.


    Regards,
    J. van Vierzen


    EDIT:

    Actually i found the answer on this very forum :)

    http://www.howtoforge.com/forums/showthread.php?t=196&page=2&highlight=ftp login failed

    Thanks, worked flawlessly!
     
    Last edited: Jan 28, 2008
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    proftpd is running on your server and there is no firewall. Are you sure that you used the correct login details. The FTP username has the form web[ID]_user and is created on the user & email tab of the site. Do not mix it up with the client login details.
     
  6. J4zen

    J4zen New Member

    This solved my issue :) Thanks though.
    http://www.howtoforge.com/forums/sho...login fa iled
     
  7. surajlk

    surajlk New Member

    Indeed I used the same user name to login outside the ISPConfig. you could see the links below. Web-FTP is working fine with ISPConfig with the same username and password. But from a different PC it denies the same username password.

    Site General:
    http://picasaweb.google.com/suraj.wellala/TechPics/photo#5160734298227724642
    [​IMG]

    Site User:
    http://picasaweb.google.com/suraj.wellala/TechPics/photo#5160734306817659250
    [​IMG]

    Is there any problem with proftpd.conf to restrict certain access while configuring ISPConfig?

    Thanks
    Suraj
     
    Last edited: Jan 29, 2008
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    @surajlk: Please post the output of the commands:

    netstat -tap

    and:

    iptables -L

    (the output is missing in your post above.)
     
  9. surajlk

    surajlk New Member

  10. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Did you try both active and passive FTP? Is your server behind a router? If so, did you forward the ports 20 and 21 to your server?
     
  11. surajlk

    surajlk New Member

    I tried both active and passive it didn't work.

    However I saw in one of the threads that by re-installing proftpd it worked. so removed proftpd and re-installed now its working. I'm not sure what exactly went wrong but the problem is solved for the moment. I'm also planing to deploy webmail I hope it will also go smoothly.

    Thank you all your guys helping me out and I'm really adopting to linux. its a brilliant platform.

    Thanks once again.:)
     

Share This Page