fstabs empty after installing debian 9 and ISPCONFIG 3

Discussion in 'Installation/Configuration' started by casinad, Apr 23, 2020.

  1. casinad

    casinad New Member

    Hello,

    I followed this tutorial :
    https://www.howtoforge.com/tutorial...-stretch-apache-bind-dovecot-ispconfig-3-1/2/

    I applied it on fresh install vps

    I got an issue at step 14

    My fstab file is empty ! i have only this line: # UNCONFIGURED FSTAB FOR BASE SYSTEM

    so i tried df -T and got those details:

    /dev/zd1152 ext4 20511312 2035400 18459528 10% /
    none tmpfs 492 0 492 0% /dev
    udev devtmpfs 49448076 0 49448076 0% /dev/tty
    tmpfs tmpfs 49499492 0 49499492 0% /dev/shm
    tmpfs tmpfs 49499492 16552 49482940 1% /run
    tmpfs tmpfs 5120 0 5120 0% /run/lock
    tmpfs tmpfs 49499492 0 49499492 0% /sys/fs/cgroup
    tmpfs tmpfs 209712 0 209712 0% /run/user/0



    Any help ? can i just skip this step or there is a correct way to edit my fstab ?

    thanks
     
    Last edited: Apr 23, 2020
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, just skip the step as the kind of vps you use does seem to configure the filesystem outside of the container.
     
  3. casinad

    casinad New Member

    Thank you sir. i also skipped those commands because not permitted:
    mount -o remount /
    quotacheck -avugm
    quotaon -avug

    One last question please, at step 19 (Install Rouncube):
    "Password of the databases administrative user: <-- enter the MySQL root password here"

    I put another password, not my MySQL root password. is that okay ? if not, how to change it ?

    Thank you in advance
     
    Last edited: Apr 23, 2020
  4. nhybgtvfr

    nhybgtvfr Active Member

    if you typed the wrong password there, I believe it will have failed to create the database. it should have told you it was unable to install the database at that time. it may be you can find the relevant user/privilege creation in the install script, and the sql file to run and do those parts manually. some other parts of the install may also have failed as a result though, so it's probably best to try to re-install/reconfigure roundcube properly.
    you could try apt-get remove and apt-get purge and then start the roundcube install from the beginning again, or you could try following this: https://www.howtoforge.com/community/threads/repair-broken-roundcube.68997/
     

Share This Page