Frustrated with ISPConfig Install V2.2.29

Discussion in 'Installation/Configuration' started by bcaza, Mar 5, 2009.

  1. bcaza

    bcaza New Member

    OK, I know I am new when it comes to Linux, but let me spell out what I have done and hopefully someone can supply an answer.

    I installed Ubuntu 8.1 (Client I believe as I tried to get the server version but it seemed to point me to the same file. If anyone has a good link to it, it would be appreciated...) and went through the steps to set it up as a LAMP system (This was not automatic, I had to install the Apache, PHP and MYSql Manually).

    I then set the password for root.

    I gave it a static IP (192.168.2.150). Network settings are correct as I can surf the net.

    I installed gcc using sudo apt-get install gcc build-essential

    I then installed the following:

    sudo apt-get install sendmail
    sudo apt-get install quota
    sudo apt-get install vsftpd
    sudo apt-get install bind9
    sudo apt-get install flex
    sudo apt-get install libmysql++-dev

    Did an SU to root successfully

    I then ran the ./setup

    Selected 2 - English

    Selected 1 - Standard

    Selected Yes for the prompts. The install then began.

    I was prompted for mysql server, but when I put in the IP, it said it was not found (Even though I could ping it from another PC). got by this by typing in localhost. Was able to enter root for the MYSql user and password was successful.

    When asked for a name for the ISPConfig database, I used the example (db_ispconfig)

    IP address for the ISPConfig web I put as localhost as that was all it would take.

    Entered www for the host name
    entered domainname.ca (where domainname is the actual name)

    Selected 2 for HTTP

    I get a lot of no such files or directories, such as /home/admispconfig/ispconfig/sysconf.txt and a bunch of others.

    I do get the message "Please direct your browser to http://www.xxxxxx.ca:81 and the login credentials, but when I go there, I get a Failed To Connect message.

    Can ANYONE point out my errors? I've redone this 4 or 5 times thinking I've messed something up. Maybe it's just that I've missed something or done something wrong.

    Thanks
     
  2. toolswizard

    toolswizard New Member

  3. falko

    falko Super Moderator ISPConfig Developer

    Just use localhost.

    Use the IP address of the server that you're installing ISPConfig on. You can find it out by typing
    Code:
    ifconfig
    If you follow this guide, there should be no problems: http://www.howtoforge.com/perfect-server-ubuntu-8.10
     
  4. jnsc

    jnsc rotaredoM Moderator

    is xxxxxx.ca defined on an external DNS?
     
  5. bcaza

    bcaza New Member

    Well, I'm setting up a new server and going throught this "Perfect Server" stuff, but it seems to me like a lot of stuff just to setup a LAMP system and run ISPConfig to manage my websites.

    Why can't I just do the LAMP iinstall from the Ubuntu server CD and do the ISPConfig setup mentioned in the Perfect Server document?

    There must be an easier way for a noob like me in Linux to do this.

    Just looking for the basics right now.

    Thanks
     
  6. bcaza

    bcaza New Member

    yes, xxxx.ca is defined on an external DNS. Zoneedit.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Quote from the tutorial:

    Of course, you can install the LAMP package during the initial server installation, but that gives you less control over what really gets installed.
     
  8. bcaza

    bcaza New Member

    OK, giving it one last try, and if I have questions, I will post them here.

    First question. After you set the IP address, you go in and edit the /etc/hosts file.

    I understand that the second line of 127.0.0.1 has to be changed to the IP address that I just gave it, but the FQDN is set to webserver.cogeco.net (name I gave it and the cogeco.net is my ISP)

    Should I leave it and just change the IP, or do I change the cogeco.net? If so, do I change it to my domain (xxxxx.ca)?

    Thanks, and I appreciate ALL the help and patience.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Just add a new line to /etc/hosts. If your IP address is 123.123.123.123 and your domain is mydomain.com, you add:

    123.123.123.123 mydomain.com
     
  10. bcaza

    bcaza New Member

    OK, I get to just before the DNS part, and do a

    quotacheck -avugm

    and get a message that says

    cannot find filesystem to check or filesystem not mounted with quota option.

    I did look at the /etc/fstab and it looked like it should. I didn't make a change to it.

    Any ideas?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Is this a vserver?
    2) Post the content of /etc/fstab
     
  12. bcaza

    bcaza New Member

    Not A Vserver

    root@webserver:/home/administrator# more /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=e3df128a-5c4e-4569-a258-47b6f311f452 / ext3 relatime,errors=remount-ro 0 1
    # /dev/sda5
    UUID=4db73368-eef2-42d2-b436-7c3991b850d0 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    root@webserver:/home/administrator#
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    You have not enabled quota in /etc/fstab as the howto describes it. Thats why you get the error. Please take a look at the howto and add the ",usrquota,grpquota" part in the line for the / filesystem.
     
  14. bcaza

    bcaza New Member

    well, the quotacheck works now after fixing those changes, but I get a new message:

    quotacheck: your kernel probably supports journalized quota but you are not using it. Consider switching to journalized quota to avoid running quotacheck after an unclean shutdown.

    Is this normal? Is there something else I should be changing?

    As always, THANKS!
     
  15. bcaza

    bcaza New Member

    Also, it did scan /dev/sda1 [/] and came back done
    Checked 3732 directories and 30936 files.

    When I do the quotaon -avug, it reports device or resource busy for quota.group and quota.user
     
  16. bcaza

    bcaza New Member

    Thanks to all who have helped! I now have the server setup and ISPConfig installed and running.....

    If anyone has an answer about that quota question, it would be appreciated.

    Again, Thanks to all!
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    The quota is ok, dont worry about it.
     

Share This Page