Frontpage Extensions 2002 - Apache 2.0

Discussion in 'Installation/Configuration' started by rvarkevisser, Mar 11, 2007.

  1. rvarkevisser

    rvarkevisser New Member

    RTR doesn't support FP50 anymore so I have no idea how I can install the frontpage extensions. When I download the FP50.linux.tar.Z from Microsoft, it doesn't include the directory .../version5.0/apache2. So I think RTR has it's own build of FP50.linux.tar which includes the apache2 directory. But how can I obtain that file???
    I managed to get the install script from rtr of the internet. All I need is the modified FP50.linux.tar.Z.

    Who can help me out or knows how I can install FP50 for apache 2.0 on a debian server?
     
  2. rvarkevisser

    rvarkevisser New Member


    Solved the problem. I managed to get the FP50 and in it installed with only 1 problem. Somehow, when I run owsadm -o setadminport -p 8090 (or whatever) it says cannot resolve host name <servername>. Which is very strange because my hostfile has the hostname bind to the external ip. Who knows this?

    Also. I've been able to get WebDav working for every website using the web admin account set in ISPConfig. I will drop the config to the tips and installation soon. I have to do some testing. For now it seems to work beautifull.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Do you have a DNS record for your servername?
     
  4. rvarkevisser

    rvarkevisser New Member

    Yep and I can connect to the default port 80 from the internet. Ping works, but that's a little low protocol to test with. So what I did was added these lines to /etc/apache2/sites-available/default and changed the first NameVirtualHost/VirtualHost * to NameVirtualHost/VirtualHost *:80.

    Listen 8090
    NameVirtualHost *:8090
    <VirtualHost *:8090>
    DocumentRoot /usr/local/frontpage/version5.0/exes
    DirectoryIndex fpadmcgi.exe
    <Directory /usr/local/frontpage/version5.0/exes/>
    AddHandler cgi-script .exe
    Options ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    In /etc/apache2/httpd.conf I added the following line:
    LoadModule frontpage_module /usr/lib/apache2/modules/mod_frontpage.so

    When I connect to http://<servername>.<domain>.nl:8090 I get an access denied. ??
    When I run /usr/local/frontpage/version5.0/bin/owsadm.exe -o setadminport 8090 ...... I get: cannot resolve host name <servername> (without the domainname!!)

    The default site is /usr/local/frontpage/version5.0/exes. Does anybody know the rights of this folder?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Do you have valid DNS servers in /etc/resolv.conf?
     
  6. rvarkevisser

    rvarkevisser New Member

    64bits vs 32bits

    Falko,

    Thrust me, when I say, DNS and local host file resolving works perfectly. I tried everything. The DNS servers are correct and I can resolve my servername web01, the local host file is correct (even removed all the records to only the localhost and web01 bind to 127.0.0.1).

    So I did something drastically. I created a new VM server, but this one based on Debian 32 bits. I use all 64bits version for the "problem" server. And guess what, it works on the 32 bits version without any problem. So I reinstalled a new VM server with the 64bits version of Debian and again I get the resolve problem!

    I use exactly the same config and packages except for php5 which I didn't install on the 64bits version.

    The hostfile and DNS servers are even the same.

    So what to do?? I'm now at that point of using a 32 bits version for the server instead of a 64bits... Don't know if it will downgrade the performance a lot. I run VMware server 64bits on debian etch, amd64 dual core and web01 is a virtual server with OS debian sarge amd64. (and all this for the many customers who use frontpage)

    who can help me?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    As long as you dont have more then 3 - 4 GB RAM, 32Bit linux is in most cases faster the 64Bit linux.
     
  8. rvarkevisser

    rvarkevisser New Member

    Is this the end?

    I installed the 32-bit Debian Sarge with Frontpage extensions and ISPConfig. This is what I did.

    I downloaded the fpprep.sh tool who will combine all the config files of apache2 to 1 file httpd.conf. I included the file /etc/apache2/vhosts/Vhosts_ispconfig.conf. This is, because when you run oswadm.exe without combining all config files to 1 file and select the serverconfigfile /etc/apache2/vhosts/Vhosts_ispconfig.conf you will get error messages like " ...... Vhosts_ispconfig.conf has no Port or ServerRoot directive."
    I ran fp_install.sh and installed the root site on port 9090. This works! I can access the web through http://web.<domain>.nl:9090 and login on the site. When I want to enable the website www.test.nl with frontpage through the website; when I press Submit it wants to download fpadmcgi.exe. ???

    When I want to enable the website through the console, I first run the "fpprep.sh install" to combine the config files to httpd.conf. Then I run the following command:

    /usr/local/frontpage/version5.0/bin/owsadm.exe -o install -u -s /etc/apache2/httpd.conf -m "www.test.nl" -u fpadmin -pw password -xu username -xg users -p 80

    I get the the following error:
    -------------
    Note: Local version of Apache must use the FrontPage Apache patch.
    Starting install, port: 80.

    Creating web http://www.test.nl:80.
    Segmentation fault
    -------------
    The website is only activated administratively. When I enter the frontpage website I see www.test.nl:80 - Administration
    In the directory /home/www/web1/web/ there's only the directory vti_pvt

    I ran fpprep.sh restore and restarted apache2. The site www.test.nl is still not activated and I can not upload with frontpage. ?

    Last but not least. ISPconfig uses the account admin for frontpage administration. I used fpadmin and I edited the config.lib.php to change the account. Also my oswadm.exe doesn't accept the variable -t apache2.0, maybe it's because I use a different version?? I don't know.
    But after I enable the frontpage extensions in ISPconfig and set the fp password in de settings, the frontpage extensions are not enabled for www.test.nl. Also in this case I ran fpprep.sh install first and after ISPconfig ran the command oswadm.exe, I ran fpprep.sh restore.

    I'm just wondering how people get this mickeysoft extension to work, because I don't have a clue.... The comming days I'm still gonna try getting this to work, so if you have an idea, please let me know.
     
  9. rvarkevisser

    rvarkevisser New Member

    Problem found

    Oke... found the problem. My package fp50.linux.tar.gz was defect. I managed to get another one, which does work!!! But still have one problem.
    When compiling the frontpage module I get some errors. And FrontpageEnabled in the vhost doesn't work.

    /usr/local/frontpage/version5.0/apache2/mod_fpcgid.c: In function `get_req':
    /usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:308: warning: dereferencing type-punned pointer will break strict-aliasing rules
    /usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:309: warning: dereferencing type-punned pointer will break strict-aliasing rules
    /usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:311: warning: dereferencing type-punned pointer will break strict-aliasing rules
    /usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:316: warning: dereferencing type-punned pointer will break strict-aliasing rules
    /usr/local/frontpage/version5.0/apache2/mod_fpcgid.c:319: warning: dereferencing type-punned pointer will break strict-aliasing rules

    I'm not sure what the problem is. Maybe somebody can tell me what it is and where to look for.

    Also, did somebody get frontpage 2002 ext. working with ISPconfig and apache 2.0?
    It wants to edit Vhosts_ispconfig.conf, but you will get error messages saying it doesn't include the ServerRoot directive etc. (when running the same "script" (don't know the english words) as in config.lib.php, with little changes like account and passwords)
     
  10. pcotter

    pcotter New Member

    That i would like also to know.... Did someone successfully installed FP2 ext. in a Debian Etch/Ispconfig box ?
     
  11. mdav

    mdav New Member

    Frontpage2002 in Etch/ispconfig box

    Hi all,

    I have the same question ... as it is not a success sofar. I'm thinking of kicking FP users out of the box :)

    thanks
    Michel
     

Share This Page