Frontpage admin port 9090

Discussion in 'Installation/Configuration' started by t.roijers, Jun 4, 2006.

  1. t.roijers

    t.roijers New Member

    Hello,

    I'm working with the frontpage extentions & Ispconfig just fine.
    I only have a problem with forms. It seems i have to install the frontpage adminport so i can set mailserver settings to enable sending email from html forms.

    I installed the port:
    /owsadm.exe -o setadminport -p 9090 -t apache-2.0 -s /etc/apache2/vhosts/Vhosts_ispconfig.conf -username administrator -pw mypassword

    Now at the bottom of the file /etc/apache/vhosts/Vhost_ispconfig.conf looks like this:

    Listen 9090
    <VirtualHost _default_:9090>
    DocumentRoot /usr/local/frontpage/version5.0/admin-exes
    DirectoryIndex fpadmcgi.exe
    <Directory /usr/local/frontpage/version5.0/admin-exes/>
    AddHandler cgi-script .exe
    Options ExecCGI
    AllowOverride All
    </Directory>
    </VirtualHost>

    It works, only when i change something in ispconfig for a web these lines are gone. I think ispconfig rewrites the Vhosts_ispconfig.conf file everytime something is changed.

    Now what i would like to know:

    Where can i put the settings so i stays there when i change somehing in ispconfig.

    Thanks so far,
    Tim
     
    Last edited: Jun 4, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Frontpage puts its configuration in the wrong file.

    Put these lines at the end of your httpd configuration, right below the line where the Vhosts_ispconfig.conf is included.
     
  3. t.roijers

    t.roijers New Member

    That seems to work


    Thanx,
    It works.. I tried similair when installing the admin port.
    I pointed to the httpd.conf instead of the Vhosts_ispconfig.conf file but it complained that there was no server root directive.

    But cut and paste from the vhost_ispconfig.conf to the httpd.conf solves the problem :)
     

Share This Page