Friendly urls problem (before set suPHP)

Discussion in 'Installation/Configuration' started by little_oak, Jan 11, 2009.

  1. little_oak

    little_oak New Member

    I used how to http://howtoforge.com/install-suphp...tions-for-use-with-ispconfig-2.2.20-and-above
    My IspConfig server working fine... but my wordpress don't worked...

    www.tinews.org (check this).

    My error_log is:

    Code:
    [Sat Jan 10 23:19:58 2009] [error] [client 201.58.46.58] PHP Warning:  PHP Startup: magickwand: Unable to initialize module, referer: http://www.tinews.org/
    [Sat Jan 10 23:19:58 2009] [error] [client 201.58.46.58] Module compiled with module API=20050922, debug=0, thread-safety=0, referer: http://www.tinews.org/
    [Sat Jan 10 23:19:58 2009] [error] [client 201.58.46.58] PHP    compiled with module API=20060613, debug=0, thread-safety=0, referer: http://www.tinews.org/
    [Sat Jan 10 23:19:58 2009] [error] [client 201.58.46.58] These options need to match, referer: http://www.tinews.org/
    [Sat Jan 10 23:19:58 2009] [error] [client 201.58.46.58]  in Unknown on line 0, referer: http://www.tinews.org/
    [Sat Jan 10 23:20:15 2009] [error] [client 201.42.68.112] PHP Warning:  PHP Startup: magickwand: Unable to initialize module,
    
    Thanks.
    :(
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Did you enabled suPHP mode in the ISPConfig configuration file /home/admispconfig/ispconfig/lib/config.inc.php ?
    If not, change the line $go_info["server"]["apache2_php"] = 'addtype' or $go_info["server"]["apache2_php"] = 'both'; into $go_info["server"]["apache2_php"] = 'suphp';

    You also must remove all the phpadmin entries within the original Vhosts_ispconfig.conf file and restart apache afterwards.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This looks for me as if your php has been updated after you installed a manually compiled php module (magickwand). You should try to recompile and reinstall this module against the current php version.
     
  4. little_oak

    little_oak New Member

    Persists...

    Code:
    Package php-magickwand - 0.1.9-2.el5.i386 is already installed.
    Package ImageMagick-c++ - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-c++ - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-devel - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-devel - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-perl - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-perl - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-c++-devel - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-c++-devel - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-c++ - 6.2.8.0-4.el5_1.1.i386 is already installed.
    Package ImageMagick-c++ - 6.2.8.0-4.el5_1.1.i386 is already installed.
    
    
    [root@balder577 ~]# php -v
    PHP Warning:  PHP Startup: magickwand: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP    compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
     in Unknown on line 0
    PHP 5.2.8 (cli) (built: Jan  5 2009 15:12:04)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
    
    
    I don't understand... :(
     
  5. little_oak

    little_oak New Member

    No compilled

    I don't compiled, i used yum.
    :(
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    updatedb
    locate magickwand
    ?
     
  7. little_oak

    little_oak New Member

    result...

    Code:
    [root@balder577 ~]# updatedb
    [root@balder577 ~]# locate magickwand
    /etc/php.d/magickwand.ini
    /usr/lib/php/modules/magickwand.so
    /usr/share/doc/php-magickwand-0.1.9
    /usr/share/doc/php-magickwand-0.1.9/AUTHOR
    /usr/share/doc/php-magickwand-0.1.9/CREDITS
    /usr/share/doc/php-magickwand-0.1.9/ChangeLog
    /usr/share/doc/php-magickwand-0.1.9/LICENSE
    /usr/share/doc/php-magickwand-0.1.9/README
    /usr/share/doc/php-magickwand-0.1.9/TODO
    [root@balder577 ~]#
     
  8. falko

    falko Super Moderator ISPConfig Developer

     
  9. little_oak

    little_oak New Member

    magickwand solved, but...

    Friendly urls of wordpress don't work and don't print error messages.
    :(
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log or the web site's error log?

    Are there any .htaccess files in your web site directories? If so, what's in them?
     
  11. little_oak

    little_oak New Member

    Logs and htaccess

    Apache error_log
    Code:
    [Thu Jan 15 12:22:53 2009] [error] an unknown filter was not added: PHP
    [Thu Jan 15 12:22:54 2009] [error] an unknown filter was not added: PHP
    [Thu Jan 15 12:22:54 2009] [error] an unknown filter was not added: PHP
    [Thu Jan 15 12:22:57 2009] [error] an unknown filter was not added: PHP
    [Thu Jan 15 12:22:57 2009] [error] an unknown filter was not added: PHP
    [Thu Jan 15 12:23:00 2009] [error] an unknown filter was not added: PHP
    [Thu Jan 15 12:23:00 2009] [error] an unknown filter was not added: PHP
    
    htaccess
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    Apache Directives
    (Optional): (on ispconfig) -> empty

    account -> log -> error_log -> empty error messages

    :(
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Please try this in the Apache Directives field of the web site in ISPConfig:
    Code:
    <Directory /var/www/web1/web>
      AllowOverride All
    </Directory>
    (Replace /var/www/web1/web with the correct path.)

    http://www.howtoforge.com/forums/showpost.php?p=60042&postcount=5
     
  13. little_oak

    little_oak New Member

    I have a problem... :(

    i try it, but don't work, however i checked file /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf and inserted all matches for wordpress rewrite, this worked, i don't understand, my apache don't read .htaccess file in main directory web, i tried it, work fine in /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf, but in .htaccess -> /var/www/web6/web <- don't work.

    :(
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    The file Vhosts_ispconfig.conf can not be edited manually. You have to insert the custom apache directives in the apache directives field of the website.
     

Share This Page