Fresh Install

Discussion in 'Installation/Configuration' started by majorpayne, Dec 31, 2009.

  1. majorpayne

    majorpayne New Member

    I started a install of ISPConfig 2 following the The Perfect Server - Ubuntu Karmic Koala (Ubuntu 9.10) [ISPConfig 2]

    everything went smoothly until I ran into installing ispconfig itself. for the past 30 mins it is sitting on Mail-SpamAssassin-3.2.5/sql and hasn't move. I'm afraid it's hung up.

    I'm afraid that I'm going to have to start over... Can anyone help me?

    Do I just need to restart the isp install or does it have to start from the beginning..

    If that's the case I'm going to write a install file to do all of the instructions for me without having to type it all in again..
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please press ENTER.
     
  3. terrapin893

    terrapin893 New Member

    I'm having the exact same problem, and when I click ENTER, it just advances a line and does nothing more. Now its still stuck there on Mail-SpamAssassin-3.2.5/sql, and the cursor is solid one line beneath where it was before I clicked ENTER. Help please!!!!

    Ive gone through so much to install everything!
     
  4. terrapin893

    terrapin893 New Member

    And just for clarification I have followed all the steps of setting up ISPConfig 2 the Perfect Server Guide for Ubuntu Karmic 9.10 Server.


    So again, where do I go from here. Do I have to scrap the installation and start the whole project again, including installing everything for the server or can I fix what is not working here and try to re-install ISPConfig2?
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are there any errors/warnings in the ISPConfig installation log in the /var/log/ directory?
     
  6. terrapin893

    terrapin893 New Member

    Checked the log files for install_ispconfig and everything seems OK in there ...

    Code:
    Tue Feb 16 10:08:08 MST 2010 - [ISPConfig] - selected language: en
    Tue Feb 16 10:08:11 MST 2010 - [ISPConfig] - installation note accepted
    Tue Feb 16 10:08:13 MST 2010 - [ISPConfig] - licence accepted
    Tue Feb 16 10:08:16 MST 2010 - [ISPConfig] - installation mode: standard
    Tue Feb 16 10:08:20 MST 2010 - [ISPConfig] - mail: postfix
    Tue Feb 16 10:08:20 MST 2010 - [ISPConfig] - dist_mail=postfix ##
    Tue Feb 16 10:08:20 MST 2010 - [ISPConfig] - dist_mail_log=/var/log/mail.log ##
    Tue Feb 16 10:08:20 MST 2010 - [ISPConfig] - dist_mail_virtusertable=/etc/postfix/virtusertable ##
    Tue Feb 16 10:08:20 MST 2010 - [ISPConfig] - dist_mail_local_host_names=/etc/postfix/local-host-names ##
    Tue Feb 16 10:08:23 MST 2010 - [ISPConfig] - ftp: proftpd
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - dist_ftp=proftpd ##
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - dist_ftp_conf=/etc/proftpd.conf ##
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - dist_ftp_version=standalone ##
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - dist_ftp_log=/var/log/xferlog ##
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - procmail found: /usr/bin/procmail
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - quota found: /usr/bin/quota
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - mysql found: /usr/bin/mysql
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - openssl found: /usr/bin/openssl
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - named found: /usr/sbin/named
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - iptables found: /sbin/iptables
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - httpd found: /usr/bin/httpd
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - httpd syntax ok!
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - dist_path_httpd_root=/var/www ##
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - gcc found: /usr/bin/gcc
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - make found: /usr/bin/make
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - flex found: /usr/bin/lex
    Tue Feb 16 10:08:24 MST 2010 - [ISPConfig] - g++ found: /usr/bin/g++
    Tue Feb 16 10:08:28 MST 2010 - [ISPConfig] - symbolic link from /var/lib/mysql/mysql.sock to /var/run/mysqld/mysqld.sock created
    Tue Feb 16 10:08:28 MST 2010 - [ISPConfig] - Directory /var/www/sharedip created.
    Tue Feb 16 10:08:28 MST 2010 - [ISPConfig] - Use sharedip_index.html_en as SharedIP default page.
    
    I also went ahead and installed the server from scratch using your guide and the same problem happens, it just freezes on that last line about SpamAssassin.
     
  7. terrapin893

    terrapin893 New Member

    Well, I am not prone to giving up . . . and it seems in this case that was very helpful.

    At first I had planned on going ahead and just putting my wordpress site up without ISPConfig, just using the command line, so I uncommented php from /etc/mime.types

    Then I decided to give the install one more chance . . . . and it worked. Installed all the way. So, perhaps, php5 is needed for the install?


    EDIT: Referring to step 17.1 Disable PHP Globally.

    http://www.howtoforge.com/perfect-server-ubuntu-9.10-karmic-koala-ispconfig-2-p6
     
    Last edited: Feb 17, 2010
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    No, the installer uses its own PHP interpreter.
     
  9. terrapin893

    terrapin893 New Member

    Well then the only other thing that was different is that previous times I had FTP'ed up and untarred and tried to install from /home/user/ftp/install_ispconfig and this time I moved the directory to /tmp/install_ispconfig.

    Those are absolutely the only two things that I did differently.
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Hm, strange... Maybe it was a problem with the size of your partitions? What's the output of
    Code:
    df -h
    ?
     
  11. terrapin893

    terrapin893 New Member

    And as for me enabling php in /etc/mime.types . . . . that had nothing to do with it, you were correct. I checked the /etc/mime.types after installation and the installation had commented them all out as "#ISPCONFIG INSTALLATION#
     
    Last edited: Feb 18, 2010
  12. RMANN

    RMANN New Member

    Install Problem

    I encountered the same problem.. when installing the ispconfig from the /tmp directory... however.. I change my /home/usrname directory to install.., it went through fine ..
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Well, the size of your partitions is ok, so that was not the problem. I have no idea... :(
     

Share This Page