Fresh install on Ubuntu 20.04 fails

Discussion in 'Installation/Configuration' started by astabski, Feb 9, 2021.

  1. astabski

    astabski New Member

    I'm trying hard to install IPSConfig 3.2 (Perfect Server, Ubuntu 20.04) from yesterday. It's getting better but IPSConfig still doesn't work. The installation process ends with a success message but the panel page (port 8080) is not displayed. The webserver works fine and the landing page displays correctly on port 80 and 443. Fierwall has port 8080 open. The configuration of Postfix, Dovecot and other items is not fine-tuned yet, but does this affect HTTP 408 ?. I am attaching the following files and please help:
    - htf_report.txt
    - ufw-status.txt
    - php7.4-fpm-log.txt (tail)
    - syslog.txt tail)
    - systemd-quotacheck-service-status.txt
    - apache2-error-log.txt (tail)
    I am very concerned about the message I saw in systemd-quotacheck status output:

    "... quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    ... Please turn quotas off or use -f to force checking
    ... systemd-quotacheck.service: Main process exited, code=exited, status=1/FAILURE
    ... systemd-quotacheck.service: Failed with result 'exit-code'.
    ... Failed to start File System Quota Check."
     

    Attached Files:

  2. Steini86

    Steini86 Active Member

    Do you get a timeout, a connection refused, another error message, a blank page or something else? Have you created the SSL certificate for the panel? Are you using https:// ?
    Anyrhing in /var/log/apache2/error.log?
     
  3. astabski

    astabski New Member

    @Steini86
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.vhost:7
    VirtualHost configuration:
    *:8081 olsza.ovh (/etc/apache2/sites-enabled/000-apps.vhost:9)
    *:8080 olsza.ovh (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
    *:80 olsza.ovh (/etc/apache2/sites-enabled/olsza.ovh.conf:1)
    *:443 olsza.ovh (/etc/apache2/sites-enabled/olsza.ovh.conf:14)
    ServerRoot: "/etc/apache2"
    Main DocumentRoot: "/var/www/html"
    Main ErrorLog: "/var/log/apache2/error.log"
    Mutex fcgid-pipe: using_defaults
    Mutex authdigest-opaque: using_defaults
    Mutex watchdog-callback: using_defaults
    Mutex rewrite-map: using_defaults
    Mutex ssl-stapling-refresh: using_defaults
    Mutex authdigest-client: using_defaults
    Mutex fcgid-proctbl: using_defaults
    Mutex ssl-stapling: using_defaults
    Mutex proxy: using_defaults
    Mutex ssl-cache: using_defaults
    Mutex default: dir="/var/run/apache2/" mechanism=default
    Mutex mpm-accept: using_defaults
    PidFile: "/var/run/apache2/apache2.pid"
    Define: DUMP_VHOSTS
    Define: DUMP_RUN_CFG
    Define: MODPERL2
    Define: ENABLE_USR_LIB_CGI_BIN
    User: name="www-data" id=33
    Group: name="www-data" id=33
     
  4. Steini86

    Steini86 Active Member

    Do you have something in-between your server and the internet? It looks like I can connect to it sometimes (or are you playing? ;) )
    From my home computer I can not connect. From my server I can connect via IPv6 but not via IPv4.
    For your IPv6, you have the Address 0 (2001:41d0:d:34ee:: ) which is technically fine, but some clients have problems with it. I would suggest to use ::1 for your server.
    Anyway, IPv4 should work and I don't know why its not. Maybe you have a firewall somewhere?
     
  5. astabski

    astabski New Member

    No. I just made some changes to the FPM configuration. I removed mod_php7.4, mpm_prefork and a2enmod mpm_event and enabled php7.4-fpm but no efects. I think it has to do with FPM. I will not do anything for now.
     
  6. Steini86

    Steini86 Active Member

    Your website is working. The ISPC interface is not using php-fpm, so that has nothing to do with it. Your server does not answer on that port. So it is a firewall or dns problem. Will not look any more today, try as you like ;)
     
  7. astabski

    astabski New Member

  8. astabski

    astabski New Member

    Problem solved. The reasons were incorrectly DNS and IPv6 settings.:)
     
    Steini86 and ahrasis like this.
  9. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    With the change he mentioned, it actually would be.
     
  10. astabski

    astabski New Member

    IPv6 was set incorrectly in /etc/systemd/network/pub.network (2001: 41d0: d: 32ee :: 0 instead of 2001: 41d0: d: 34ee :: 0). Ping6 was losing all packets. I didn't notice this before, because on this server BIND9 was not used before and IPv6 was not used. There were also some bugs in setting up the firewalls. Well, tiredness. I have to reinstall the whole system anyway because the quota service cannot be started. You need to create a partition for the /var/www directory and assign quota here, not to /. Thanks for the help
     
    Last edited: Feb 10, 2021
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not the case, assgning quota to / works perfectly fine. I'll use that on all of my systems. But of course, you can create a separate partition if you prefer that.
     
  12. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Sure, I don't mean that was your problem (I actually recommend everyone remove mod_php), I just meant that by removing mod_php and enabling php-fpm as your default php interpreter (and switching mpm modules), ISPConfig actually would be run via php-fpm -- and I was wrong. Just checking a Debian 10 system, the ispconfig vhost is setup to use fastcgi mode (php-cgi).

    Sorry for calling that out incorrectly, @Steini86.
     
  13. astabski

    astabski New Member

    Installing ISPConfig on Ubuntu 20.04 doesn't always go smoothly. Before that, it is good to know that:

    1) Some ISPs provide dedicated servers with a Ubuntu used to virtual cloud-based system (eg OVH). The kernel then has no modules needed to using of quotas. You can find this out when you try to turn on quotas after installing Quota with the command 'quotaon -avug':

    quotaon: using /var/quota.group on /dev/md126 [/var]: No such process
    quotaon: Quota format not supported in kernel.

    In that case it is need to install 'linux-image-extra-virtual' as described in https://technowikis.com/38498/install-quota-and-create-ubuntu-20-04-or-20-10-disk-quotas.

    2) I thinks, it is safer to separate a partition for a directory which need to quotas (eg /var) rather than enable quotas on the entire filesystem (ie /).

    3) If you want to configure some websites outside the control of ISPConfig (e.g. in the /var/html directory), you must do so before installing Quota and ISPConfig.

    It would be good to mention it at https://www.howtoforge.com/tutorial/perfect-server-ubuntu-20.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/ .

    It doesn't change the fact that ISPConfig is great!
     
    Last edited: Feb 17, 2021

Share This Page