Fresh Install of Ubuntu 10.04 and ISPConfig 2

Discussion in 'Installation/Configuration' started by happz, Jul 26, 2010.

  1. happz

    happz New Member

    Issue: Web (apache) will not start. states it is Offline.

    Research: I checked the error log /va/log/apache2/error

    Results:
    Code:
    [Wed Jul 21 19:21:29 2010] [notice] child pid 13686 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:29 2010] [notice] child pid 13687 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:29 2010] [notice] child pid 13688 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:29 2010] [notice] child pid 13689 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13690 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13691 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13692 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13693 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13694 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13695 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13696 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] child pid 13697 exit signal Segmentation fault (11)
    [Wed Jul 21 19:21:30 2010] [notice] caught SIGTERM, shutting down
    [Wed Jul 21 19:21:32 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/idn.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Wed Jul 21 19:21:32 2010] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Wed Jul 21 19:21:32 2010] [notice] mod_python: using mutex_directory /tmp 
    [Wed Jul 21 19:21:32 2010] [notice] Apache/2.2.14 (Ubuntu) DAV/2 PHP/5.3.2-1ubuntu4.2 with Suhosin-Patch mod_python/3.3.1 Python/2.6.5 mod_ruby/1.2.6 Ruby/1.8.7(2010-01-10) mod_ssl/2.2.14 OpenSSL/0.9.8k configured -- resuming normal operations
    [Wed Jul 21 19:24:17 2010] [notice] caught SIGTERM, shutting down
    [Wed Jul 21 19:24:18 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/idn.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Wed Jul 21 19:24:18 2010] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Wed Jul 21 19:24:18 2010] [notice] mod_python: using mutex_directory /tmp 
    [Wed Jul 21 19:24:18 2010] [notice] Apache/2.2.14 (Ubuntu) DAV/2 PHP/5.3.2-1ubuntu4.2 with Suhosin-Patch mod_python/3.3.1 Python/2.6.5 mod_ruby/1.2.6 Ruby/1.8.7(2010-01-10) mod_ssl/2.2.14 OpenSSL/0.9.8k configured -- resuming normal operations
    [Wed Jul 21 19:56:59 2010] [notice] caught SIGTERM, shutting down
    
    I attempted to restart and it appears it is yet, still in Offline Mod. This is not the full log but most of the first section is a repeat. When I tryed to restart from cmd line I get this:

    Code:
    root@gtcweb:~# /etc/init.d/apache2 restart
     * Restarting web server apache2   Syntax error on line 6 of /etc/apache2/mods-enabled/php5.conf:
    SetHandler takes one argument, a handler name that overrides any other configured handler
    
    Here is the php5.conf:

    Code:
    <IfModule mod_php5.c>
        <FilesMatch "\.ph(p3?|tml)$">
    	#SetHandler ##ISPConfig INSTALL## application/x-httpd-php
        </FilesMatch>
        <FilesMatch "\.phps$">
    	SetHandler ##ISPConfig INSTALL## application/x-httpd-php-source
        </FilesMatch>
        # To re-enable php in user directories comment the following lines
        # (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
        # prevents .htaccess files from disabling it.
        <IfModule mod_userdir.c>
            <Directory /home/*/public_html>
                php_admin_value engine Off
            </Directory>
        </IfModule>
    </IfModule>
    Help is appreciated.

    Happz
     
    Last edited: Jul 26, 2010
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    ./etc/apache2/envvars && httpd -t
     
  3. happz

    happz New Member

    Results:

    Code:
    root@gtchwebsrv01:~# /etc/apache2/envvars && httpd -t
    -bash: /etc/apache2/envvars: Permission denied
    
    
     
    Last edited: Jul 26, 2010
  4. happz

    happz New Member

    Any idea's?

    I entered the output and get a permission's error. What could that mean?

    regards,
    happz
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Try just:

    httpd -t
     
  6. happz

    happz New Member

    Result:

    httpd: bad user name ${APACHE_RUN_USER}


    happz
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then the first command I posted is correct. Try it again. I just noticed that you had a typo in your output, you missed the dot at the beginning of the command.
     
  8. happz

    happz New Member

    Okay..here's the results:

    root@gtchwebsrv01:~# ./etc/apache2/envvars && httpd -t
    -bash: ./etc/apache2/envvars: No such file or directory
    root@gtchwebsrv01:~#
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Try
    Code:
    . /etc/apache2/envvars && httpd -t
    instead (space between . and /etc/apache2/envvars).
     
  10. happz

    happz New Member

    Okay..i did that

    here's the results:
    Code:
    root@gtchwebsrv01:~# . /etc/apache2/envvars && httpd -t
    Syntax error on line 6 of /etc/apache2/mods-enabled/php5.conf:
    SetHandler takes one argument, a handler name that overrides any other confid handler
    thanks,
    happz
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/apache2/mods-enabled/php5.conf?
     

Share This Page