Fresh Install of FC4 using Perfect Install HowTo

Discussion in 'HOWTO-Related Questions' started by latcarf, Jul 27, 2005.

  1. latcarf

    latcarf New Member

    During install I noted this;

    In Quota sect.
    quotacheck -avugm returned: Cant find filesystem to check or filesystem not mounted with quota option

    In MySql sect
    netstat -tap the number after listen was different something like 4322 (forgot to note it)

    /etc/my.cnf did not look anything like this! here is what I have:
    Code:
    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1
         
    [mysql.server]
    user=mysql
    basedir=/var/lib
    
    [mysqld_safe]
    err-log=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    In PERL Modules
    install Net'::'DNS I noticed one of the lines returned something like; "Error T101 Resolver File" (went to fast for me to catch it) the end returned this though:
    Code:
            5/6 skipped: Socket6 and or IO::Socket::INET6 not loaded
    All tests successful, 4 tests and 14 subtests skipped.
    Files=23, Tests=909, 22 wallclock secs (17.18 cusr +  2.31 csys = 19.49 CPU)
      /usr/bin/make test -- OK
    Is there anything here that needs to be fixed?

    Lance aka latcarf
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You need to edit /etc/fstab and add
    Code:
    ,usrquota,grpquota
    to one of your partitions, like here:
    Code:
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/                 /                       ext3    defaults,usrquota,grpquota        1 1
    LABEL=/boot             /boot                   ext3    defaults        1 2
    /dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
    /dev/shm                /dev/shm                tmpfs   defaults        0 0
    /dev/proc               /proc                   proc    defaults        0 0
    /dev/sys                /sys                    sysfs   defaults        0 0
    LABEL=SWAP-sda3         swap                    swap    defaults        0 0
    /dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,managed 0 0
    /dev/hdc                /media/cdrecorder       auto    pamconsole,exec,noauto,managed 0 0
    Then you need to run these commands:
    Code:
    touch /aquota.user /aquota.group
    chmod 600 /aquota.*
    mount -o remount /
    quotacheck -avugm
    quotaon -avug
    (You have to adjust these commands to reflect the partition with quota; e.g. if your quota partition is /home, then the commands to execute would be
    Code:
    touch /home/aquota.user /home/aquota.group
    chmod 600 /home/aquota.*
    mount -o remount /home
    quotacheck -avugm
    quotaon -avug
    )


    Can you post the output of netstat -tap here?

    Did
    Code:
    /usr/bin/make install -- OK
    appear at the end of the installation? Did you choose no when asked for tests during the installation?
     
  3. latcarf

    latcarf New Member

    Sorry didn't know I had a reply... I guess I need to dig for the notify button. Thanks for the info.

    I will go through and see what happens. I just did another install on a second I plan to use as a secondary. I think I need to get the primary running first though! :rolleyes:

    I saw the HowTo for Postfix install, is there one somewhere that tells you how to actually use it? Same with Proftpd.

    thanks again
    lance
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What do you mean with "how to use it"? What's the problem? :confused:
     
  5. latcarf

    latcarf New Member

    Yes :)

    Thanks for the help! I have O'Riellys DNS and Bind v4 coming, hopefully it will help me understand everything we just talked about and did! :D
     
  6. latcarf

    latcarf New Member

    well... here is where I show my newbyness... I don't think there is a problem... except operator error, being really new to all this and learning :)

    Postfix is an alternate e-mail server program to Sendmail, correct?
    How do I use it? By setting up a program such as Mozilla or FireFox mail? I did read somewhere about sending mail via a console but I am not ready for that yet.

    I have placed 2 MX records in each server, one at priority 10 and the other at priority 20. I have them tagged out for now. Maybe I should be asking for documentation on how to configure an e-mail program to use my mail server?

    Same with Proftpd. Once I get the server squared away and actually open to the internet is it as easy as someone typing in ftp.mydomain.com? And they can download or upload files?
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can use an email client such as Thunderbird, Outlook, Outlook Express, etc. There you set up a new email account, as POP3 and SMTP server you enter a domain that's on your server or the server's IP address, and then you enter your user's username and password, and finally you have to activate something called "Server needs authentication" (or the like), because otherwise you wouldn't be allowed to send emails to external email addresses (SMTP-AUTH).

    Same here. You need an FTP client such as WS_FTP from Ipswitch, there you enter an IP address or domain and your user's username and password, and then that user (noone else!) will be allowed to up/download files.
     
  8. latcarf

    latcarf New Member

    Thanks, sounds simple enough. :)

    I have noticed when I shut down and and linux goes through the processes it gets to a line where it says something like "... killall Postfix [Failed]"

    I am sure there is probably a sys log somewhere that records all this. Can I take the easy way ask where it is?

    Lastly, is there a method that allows clients to place files on my FTP (proftpd) without logging in? such as anonymous?
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Go to the log directory:

    cd /var/log

    Then liszt all files in that directory:

    ls -l

    The you can see a list of all available logfiles. There is also the syslog file.

    You can set anonymous FTP inside from ISPConfig. Please read the manual.
     
  10. latcarf

    latcarf New Member

    I'll take a peek and see if I can understand what it states.

    I have not loaded ISPConfig, yet that is! I am new to all this and believe I should learn how to do this the basic way first then make my life easier by using ISPConfig to maintain.

    thanks!
    lance
     
  11. latcarf

    latcarf New Member

    I the guide for the set-up of FC4 after the the installation is done and we reboot the first thing we do is configure (or add) an additional network interface as eth0:0.

    What is the purpose of this additional interface?
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Sometimes you have more than one IP address on a server. Let's say you have your server housed in some ISP's data center, and that ISP gives you 4 IP addresses instead of one, e.g. 1.2.3.4 - 1.2.3.7, but your server does not have 4 network cards. Then you have to configure virtual interfaces (e.g. eth0:0 - eth0:2).
    If you have only one IP address, then there's no use adding virtual interfaces.
     
  13. latcarf

    latcarf New Member

    Thanks, I had a chance to back up today and look at some "networking" articles and it said the same thing, you did say it better though. They just stated you did it to have multiple IPs on one computer but didn't state why.

    Maybe you can help where that is concerned... I do have a static IP from my ISP. If I set up a DNS that will be Authoratative for my domain where do I declare this static IP in my zone files? I have not found ANY reference or examples on the internet that specify their example is using a static IP. Although one site said to edit my 127.0.0.1 localhost zone but that just does not sound right since I did gather from all the other examples that the 127.0.0.1 is needed for network loopback.

    Do you think this would work? if say my static ISP IPaddress was 74.61.x.x?
    Code:
    //the fractalfarm.net.ex.db
    //$ORIGIN thefractalfarm.net
    $TTL 1D
    @		IN	SOA	server1.thefractalfarm.net.	lance.thefractalfarm.net. ( 
    				2005073101	; serial 
    				3H
    				3H
    				1W
    				1D )
    		IN	NS	server1.thefractalfarm.net.
    		IN	NS	server2.thefractalfarm.net.
    		IN	MX	10	server1.thefractalfarm.net.
    		IN	MX	20	server2.thefractalfarm.net.
    server1		IN	A	70.61.xx.xx
    server2		IN	A	192.168.2.5
    www		IN	CNAME	server1
    ftp		IN	CNAME	server1
    I am running my services, e.g. named, httpd, mail, and ftp on one box (server1) with the network IP of 192.168.2.3 the other I listed above as server2 will be the slave DNS, and secondary mail.

    Lance
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Looks good, I'd say... :)
     
  15. latcarf

    latcarf New Member

    cool, I'll give it a try. Getting really tired of my host rejecting my DNS servers :( and the only thing I can think of is it the IPs.
     
  16. latcarf

    latcarf New Member

    I didn't even get a chance to try the zone file. Apparently I broke named last night. Couldn't get it to start, restart, or give status. I moved a bunch of files last night by accident and thought I had all back in order but I guess not.

    I did a fresh intall of FC4 and when I got to Install apt for Fedora I got this response
    Code:
    [root@server1 ~]# rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i3 86/apt-0.5.15cnc7-6.fc4.i386.rpm
    Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc 7-6.fc4.i386.rpm
    warning: /var/tmp/rpm-xfer.eIfePg: Header V3 DSA signature: NOKEY, key ID 1ac70c e6
    Preparing...                ########################################### [100%]
       1:apt                    ########################################### [100%]
    [root@server1 ~]# gedit /etc/apt/sources.list
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    
    
    (gedit:3950): Gtk-WARNING **: cannot open display:
    [root@server1 ~]# rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i3 86/apt-0.5.15cnc7-6.fc4.i386.rpm
    Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc 7-6.fc4.i386.rpm
    warning: /var/tmp/rpm-xfer.dPBU9u: Header V3 DSA signature: NOKEY, key ID 1ac70c e6
    Preparing...                ########################################### [100%]
            package apt-0.5.15cnc7-6.fc4 is already installed
    [root@server1 ~]# gedit /etc/apt/sources.list Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified
    
    
    (gedit:3960): Gtk-WARNING **: cannot open display:
    Is it fixable? I tried twice as you can see. Hopefully it just a down ftp server or something.
     
  17. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer


    As far as i know gedit is a GTK based editor that needs an Xserver. The message you got is that gedit can not be started because there is no running Xserver. When you work on the command shel, try a editor like vim, joe or or pico thst does not need an XConsole.
     
  18. latcarf

    latcarf New Member

    thats odd... gedit has been what I have used all along. Any thoughts why Xserver wouldn't have loaded or worked this time? Otherwise I guess I can get used to vi also.
     
  19. latcarf

    latcarf New Member

    Must have had a M$ virus, rebooting fixed the problem! :)

    One last question on the install. Should up2date be activated? or is there an alternative method to get updates e.g. apt-get update

    If the latter is suggested how do I get rid of that flashing red beacon!?
     
  20. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You can run up2date or apt-get update, both will work.
     

Share This Page