fresh install no CP page

Discussion in 'Installation/Configuration' started by carpman, Dec 12, 2011.

  1. carpman

    carpman Member

    Hello, done a fresh install following the perfect server guide, squurellmail page loads as does the default server page, but not the CP page

    ip:8080

    When installing there was one thing that was not in the guide and that was when given the choise to use ssl login (CP i think) it asked for inof on "extra challenge" details. I went with the default by pressing enter.

    Code:
    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:ftp                   *:*                     LISTEN      1517/pure-ftpd (SER
    tcp        0      0 carpconnect.net:domain  *:*                     LISTEN      839/named       
    tcp        0      0 localhost:domain        *:*                     LISTEN      839/named       
    tcp        0      0 *:ssh                   *:*                     LISTEN      879/sshd        
    tcp        0      0 *:smtp                  *:*                     LISTEN      1578/master     
    tcp        0      0 localhost:953           *:*                     LISTEN      839/named       
    tcp        0      0 *:imaps                 *:*                     LISTEN      1591/dovecot    
    tcp        0      0 *:pop3s                 *:*                     LISTEN      1591/dovecot    
    tcp        0      0 localhost:10024         *:*                     LISTEN      1288/amavisd (maste
    tcp        0      0 localhost:10025         *:*                     LISTEN      1578/master     
    tcp        0      0 *:mysql                 *:*                     LISTEN      1116/mysqld     
    tcp        0      0 *:pop3                  *:*                     LISTEN      1591/dovecot    
    tcp        0      0 *:imap2                 *:*                     LISTEN      1591/dovecot    
    tcp        0     48 carpconnect.net:ssh     cpc2-hari9-0-0-cu:62933 ESTABLISHED 3332/1          
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      1517/pure-ftpd (SER
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN      839/named       
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      879/sshd        
    tcp6       0      0 ::1%22741888:953        [::]:*                  LISTEN      839/named       
    tcp6       0      0 [::]:https              [::]:*                  LISTEN      3448/apache2    
    tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN      3448/apache2    
    tcp6       0      0 [::]:www                [::]:*                  LISTEN      3448/apache2    
    tcp6       0      0 [::]:tproxy             [::]:*                  LISTEN      3448/apache2    
    

    Code:
    
    iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    fail2ban-dovecot-pop3imap  tcp  --  anywhere             anywhere            multiport dports pop3,pop3s,imap2,imaps 
    fail2ban-pureftpd  tcp  --  anywhere             anywhere            multiport dports ftp 
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    target     prot opt source               destination         
    RETURN     all  --  anywhere             anywhere            
    
    Chain fail2ban-pureftpd (1 references)
    target     prot opt source               destination         
    RETURN     all  --  anywhere             anywhere          

    logs

    tail -n100 /var/log/apaceh2/error_log
    Code:
    [Mon Dec 12 16:08:27 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Dec 12 16:08:27 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Dec 12 16:08:27 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Dec 12 16:08:27 2011] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
    
    

    tail -n100 /var/log/apache2/access.log
    Code:
    127.0.0.1 - - [12/Dec/2011:16:40:02 +0000] "GET / HTTP/1.0" 200 454 "-" "-"
    127.0.0.1 - - [12/Dec/2011:16:45:01 +0000] "GET / HTTP/1.0" 200 454 "-" "-"
    
    any ideas?

    cheers
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig seems to be running according to netstat and it is not blocked by a firewall on the ispconfig server.

    1) Which error do you get in the webbrowser?
    2) Is it possible that there is some kind of router or external firewall installed between your desktop and your server?
     
  3. carpman

    carpman Member

    Thanks for reply

    the error is

    Code:
    
    Unable to connect
          
          
          
          
          
            
            
              Firefox can't establish a connection to the server at 109.235.145.21:8080. 
            
    
      The site could be temporarily unavailable or too busy. Try again in a few
        moments.
      If you are unable to load any pages, check your computer's network
        connection.
      If your computer or network is protected by a firewall or proxy, make sure
        that Firefox is permitted to access the Web.

    Yes i have firewall running, a smoothwall.org box. Port 8080 is allowed for outgoing traffic.

    logs show following blocks even with outgoing allowed.

    Code:
    17:36:23 	eth2 ยป eth1 	TCP 		192.168.1.5 	tools 	63742 		109.235.145.21 	tools 	8080
    
     
  4. carpman

    carpman Member

    I setup my internal IP to be always allowed, but still the same ?
     
  5. carpman

    carpman Member

    it is my firewall somewhere as can connect via 3g ob phone.

    can i change the port number?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can chnage the port number in /etc/apache2/sites-available/ispconfig.vhost and then restart apache2.
     
  7. carpman

    carpman Member

    Tried that but still no joy?

    Really don't know why it is doing this as i have other web control panels that work fine with outgoing ports allowed!
     
  8. carpman

    carpman Member

    Have it working now.
     

Share This Page