Freeradius sql module

Discussion in 'Server Operation' started by Camomille, Apr 10, 2009.

  1. Camomille

    Camomille New Member HowtoForge Supporter

    Hello,

    after searching too many days and doing lots of installs, I finally come and ask for help.
    Following the tuto for installing freeradius on Cent0s 5.2 , I always got following error when launching " radiusd -X ;

    Code:
    /etc/freeradius/sites-enabled/default[152]: Failed to find module "sql".
    /etc/freeradius/sites-enabled/default[62]: Errors parsing authorize section.
    
     }
    }
    Errors initializing modules
    
    
    I had same problem when installing FR on Ubuntu 8.10 and Debian Lenny!

    This is a question I found very often on the net and never saw any solution!

    Please help me ;) ;) ;)

    Great thanks for your help, comments or suggestions ;)

    Camomille
     
    Last edited: Apr 10, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    On Debian/Ubuntu, I guess you need to install the package freeradius-mysql.
     
  3. Camomille

    Camomille New Member HowtoForge Supporter

    Thanks for your reply!

    I did install freeradius-mysql on Debian & Ubuntu. I tried on systems where LAMP was installed and also tried on " minimal systems" and installed mysql afterwards!

    On Cent0s, I made my own " FR2.1.1-6.i386 centos rpm" using your tuto and installed them exactly how you described. I tried on VMware images "The_Perfect_Server_-_CentOS_5[1][1].2" and also a fresh installed Cent0s 5.3.

    I did not have such problems with Freeradius v 1....... Maybe I should try again with older 1.1.7 version !! ?? What are the great changes in new FR v2 version??
    Sorry for all thoses questions. Just a little help should be enough to put me back on the right rails ;) ;) ;)

    Great thanks and nice Sunday.

    Camo
     
  4. Camomille

    Camomille New Member HowtoForge Supporter

    Please help !!

    Sorry for being so insistant ;)

    What could be the origin of these errors ? My radius.log remains empty and I don't know in what direction to look to solve my error (Sure I did make one or more errors !! )

    I just installed FR on a Fedora 9 (Perfect Server) and had same error when executing " radiusd -X "

    Great thanks for your precious help.

    Camomille
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I have no experience with FreeRadius, but I guess that the MySQL module needs to be enabled in some configuration file.
     
  6. Camomille

    Camomille New Member HowtoForge Supporter

    Here is how I solved this

    Yes, SOLVED !!

    Sure I'm not the only one having this problem. After searching and reading docs more carefully, I finally found the cause of the problem.

    I simply had to UNcomment line 660 of radiusd.conf:
    Code:
    #$INCLUDE sql.conf
    I hope this will help some members and avoid them loosing time as I did ;) ;)

    Greetings to all.

    Camomille
     

Share This Page