[FreeBSD] Can not get BIND to work

Discussion in 'HOWTO-Related Questions' started by Sunsawe, Apr 25, 2010.

  1. Sunsawe

    Sunsawe New Member

    Hi everyone,

    I followed the BIND "how to" available on the site. I did everything that was indicated, I least, I think, but, still can not resolve names of Lan computers.

    this is the file my.domain :
    Code:
    $TTL    3600
    my.domain.                     IN    SOA     dns.my.domain.  root.my.domain. (
                                                       1            ; Serial
                                                       10800    ; Refresh
                                                       3600       ; Retry
                                                        604800  ; Expire
                                                       86400 )   ;Minimum TTL
    ; DNS Servers
    my.domain.                     IN               NS   dns.my.domain.
    
    ; Computer names and records
    dns.my.domain.   IN              A       192.168.0.22
    ftp.my.domain.   IN              A       192.168.0.21
    [url]www.my.domain[/url].   IN              A       192.168.0.23
    ; Aliases
    ftp                     IN              CNAME   ftp.my.domain.
    www                     IN              CNAME   [url]www.my.domain[/url].
    dns                     IN              CNAME   dns.my.domain.
    
    and the reverse my.domain.rev:
    Code:
    $TTL    3600
    0.168.192.in-addr.arpa.          IN    SOA    dns.my.domain.  root.my.domain. (
                                                       1            ; Serial
                                                        10800    ; Refresh
                                                       3600      ; Retry
                                                        604800   ; Expire
                                                        86400)   ; Minimum TTL
    ; DNS Servers
    0.168.192.in-addr.arpa.          IN              NS    dns.my.domain.
    
    ; Computer IPs
    22                              IN              PTR    dns.my.domain.
    21                              IN              PTR    ftp.my.domain.
    23                              IN              PTR    [url]www.my.domain[/url].
    
    I used BIND97. I can dig and ping www.google.com but if I try to ping one of the lan computers:
    If someone could tell me what I am doing wrong, that would be great.

    Thanks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does
    Code:
    dig @localhost ftp.my.domain
    work?
     
  3. matty

    matty Member

    I'd also suggest incrementing your serial numbers and then reloading bind (rndc reload, or simply restart the service). If your serials are still at 1, bind is likely to be ignoring any changes you've made to the default zone files.
     

Share This Page