Free Space Problem

Discussion in 'Installation/Configuration' started by Mario90, Aug 7, 2014.

  1. Mario90

    Mario90 New Member

    Hi,
    my sites weight 10GBs approximated and i don't understand why i'm getting space issues on my server.

    Here is a screenshot of my panel info http://s27.postimg.org/mcjrobwdf/Immagine.png

    Output df -h is :

    rootfs 20G 18G 997M 95% /
    /dev/root 20G 18G 997M 95% /
    devtmpfs 16G 0 16G 0% /dev
    tmpfs 3,2G 272K 3,2G 1% /run
    tmpfs 5,0M 4,0K 5,0M 1% /run/lock
    tmpfs 6,4G 0 6,4G 0% /dev/shm
    /dev/sda2 90G 56M 85G 1% /home
    /dev/root 20G 18G 997M 95% /var/www/clients/client2/web3/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client1/web4/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client3/web5/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client4/web6/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client6/web11/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client7/web12/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client8/web14/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client9/web15/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client10/web13/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client11/web17/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client12/web18/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client13/web19/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client14/web20/log
    /dev/root 20G 18G 997M 95% /var/www/clients/client15/web22/log

    Why is it making those subpartitions?
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Can you please paste your /etc/fstab.

    What is your distribution and ISPConfig version?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    These are not sub partitions, this are bind mounts. they dont take any space, they are basically a symlink on filesystem level and they are used to make the log directory avalable to the clients. These bind mounts are not related to your problem.

    Your problem is something different, allwebsites and email accunts are in /var, but your largest partition is home. So basically the server was partitioned wrong at the time the OS was installed.

    Here is a tutorial that shows you a solution:

    http://www.howtoforge.com/use_mount...ctory_of_a_ispconfig_server_to_a_new_location
     
  4. Mario90

    Mario90 New Member

    Output of fstab, i'm using Debian 7,5 Wheezy with ispconfig 3.0.5.4p1, 2xSSD of 128GB,kernel version Debian 7.6 3.10.23-xxxx-std-ipv6-64:

    # <file system> <mount point> <type> <options> <dump> <pass>
    /dev/sda1 / ext4 errors=remount-ro,relatime,discard,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
    /dev/sda2 /home ext4 defaults,relatime,discard 1 2
    /dev/sda3 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    devpts /dev/pts devpts defaults 0 0
    /var/log/ispconfig/httpd/mysite1.it /var/www/clients/client2/web3/log none bind,nobootwait 0 0
    /var/log/ispconfig/httpd/mysite2.it /var/www/clients/client1/web4/log none bind,nobootwait 0 0
    /var/log/ispconfig/httpd/mysite3.it /var/www/clients/client3/web5/log none bind,nobootwait 0 0
    /var/log/ispconfig/httpd/mysite4.com /var/www/clients/client4/web6/log none bind,nobootwait 0 0
    /var/log/ispconfig/httpd/mysite5.it /var/www/clients/client6/web11/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite6.it /var/www/clients/client7/web12/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite7.it /var/www/clients/client8/web14/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite8.it /var/www/clients/client9/web15/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite9.it /var/www/clients/client10/web13/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite10 /var/www/clients/client11/web17/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite11.it /var/www/clients/client12/web18/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite12.it /var/www/clients/client13/web19/log none bind,nobootwait,_netdev 0 0
    /var/log/ispconfig/httpd/mysite13.it /var/www/clients/client15/web22/log none bind,nobootwait,_netdev 0 0
     
  5. srijan

    srijan New Member HowtoForge Supporter

    Please follow the instructions as mentioned by Till, it will help you.
     
  6. Mario90

    Mario90 New Member

    Something went wrong in the moving of files and i've lost some files...is there a way to revert moving?
    I'm missing the /var/www/php-fcgi-scripts directory in main folder...how to restore that?

    Please i seriously need help... :(
     
    Last edited: Aug 7, 2014
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ispconfig, go to tools > resync, select websites and click on start.
     
  8. Mario90

    Mario90 New Member

    I cannot access to ispconfig because apache won't start...

    Warning: DocumentRoot [/var/www/apps] does not exist
    Warning: DocumentRoot [/var/www/apps] does not exist
    Syntax error on line 37 of /etc/apache2/sites-enabled/000-apps.vhost:
    Wrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter cannot be accessed: (2)No such file or directory
    Action 'configtest' failed.
    The Apache error log may have more information.
    failed!
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to disble the apps vhost by delting the link:

    rm /etc/apache2/sites-enabled/000-apps.vhost

    and then restart apache.
     
  10. Mario90

    Mario90 New Member

    Already done but i'm missing the /var/www/apps folder...how can i reget it?
     
  11. Mario90

    Mario90 New Member

    I've managed to rollback everything(luckily).
    I had a broken SSD on my OVH dedicated server, i'll get it fixed soon.
    Thanks all, you could close the post if you want :)
     

Share This Page