fpm pool files not created

Discussion in 'Installation/Configuration' started by blackwolf, Aug 5, 2019.

Tags:
  1. blackwolf

    blackwolf New Member

    after create new site or updating, ispconfig doesn't add php-fpm conf file the the pool directory

    ispconfig: 3.1.14p2
    distro : debian buster
    web server: apache
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Is this a new install, or has it worked in the past? (Eg. recently updated from stretch to buster and need to update your php settings?)

    Check your php settings under System, especially the init script setup. If you don't find anything, provide more info on your setup, eg. what php version (default or alternate php version) has a problem, how was that version installed, and what are the settings for it? Can you stop/start the daemon manually from cli?
     
  3. Xym

    Xym New Member

    Hi Blackwolf, i get the same with a fresh install. Completely strange, i few month ago 0 errors with fresh install. And now Completely out.
    I'm on Bionic 18.04, 5 fresh install, same error. Debug mode on.
    ISP don't create in the pool-d./web**.conf only the www .conf
    and no sock file in /var/lib/php7.2-fpm/ 0 file.

    I check that in the night. If you have any idea i take to speed up.
    See you.

    @Jesse Norell : i check a lot of parameter with no success, i think the error was in the template of creation or not.

    see the debug log :
    05.08.2019-23:28 - DEBUG - Enable SSL for: ***.*****.com
    05.08.2019-23:28 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/***.*****.vhost
    ====> 05.08.2019-23:28 - DEBUG - Writing the PHP-FPM config file: /web3.conf <=====================
    05.08.2019-23:28 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    05.08.2019-23:28 - DEBUG - Restarting php-fpm: systemctl reload php7.2-fpm.service
    05.08.2019-23:28 - DEBUG - Apache status is: running
    05.08.2019-23:28 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    05.08.2019-23:28 - DEBUG - Restarting httpd: systemctl restart apache2.service
    05.08.2019-23:28 - DEBUG - Apache restart return value is: 0
    05.08.2019-23:28 - DEBUG - Apache online status after restart is: running
    05.08.2019-23:28 - DEBUG - Processed datalog_id 37
    05.08.2019-23:28 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    in the folder pool.d :
    [email protected]***:/etc/php/7.2/fpm/pool.d# ls
    www. conf
    [email protected]***:/etc/php/7.2/fpm/pool.d#

    in the folder /var/lib/ (socks)
    [email protected]***:/etc/php/7.2/fpm/pool.d# cd /var/lib/php7.2-fpm/
    [email protected]***:/var/lib/php7.2-fpm# ls
    [email protected]***:/var/lib/php7.2-fpm#

    None
    Very strange.
    It's the first bug for me with this tutorial (appx 25 servers this years with 0 problem):
    perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig

    Thanks for your time, i come back if i find the bug.
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    Did /web3.conf get created? (ie. in root directory) Does "find / -name web3.conf" find the file anywhere? What do you have set for 'PHP-FPM pool directory' in System > Server Config > Web > PHP Settings ?

    Maybe there's a bug in 3.1.14p2 causing this? I've upgraded a couple debian9 systems to that version and they don't seem to have this issue, but I've not done any fresh installs.
     
  5. Xym

    Xym New Member

    Hi Jesse,
    Thanks for your help, there is nothing file with web3.conf.
    for the pool directory in the server config :
    /etc/php/7.2/fpm/pool.d
    no luck for this moment i walk step by step. For the moment ISP don't show in the debug log any information about that.
    I'm curious to check the create site template.

    Yep i have upgraded from 16.04 and no bug (other bug but it's solved ^^)

    I'l try to find in isp
     
  6. blackwolf

    blackwolf New Member

    Yes they are all in the /

    php version 7.3 with the default installation form
    https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Works perfectly fine here. Installed the server exactly as described in Debian Buster tutorial. When I add a website and activate php-fpm, then the pool config is written to /etc/php/7.3/fpm/pool.d/ as it should be on Debian 10. For Ubuntu 18.04 the directory would be /etc/php/7.2/fpm/pool.d/

    Code:
    06.08.2019-12:39 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/example.com.vhost
    06.08.2019-12:39 - DEBUG - Writing the PHP-FPM config file: /etc/php/7.3/fpm/pool.d/web1.conf
    06.08.2019-12:39 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    06.08.2019-12:39 - DEBUG - Restarting php-fpm: systemctl reload php7.3-fpm.service
    When your system is writing the file to /, then your global server config is probably damaged and no path or a wrong path is set for the pool dir under System > server config
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I was able to reproduce it in git-stable only, so probably you are using that version instead of the 3.1.14p2 release. Please update to git-stable (not git-master!) with ispconfig_update.sh command and check if the pool file is still created in the wrong location.
     
  9. blackwolf

    blackwolf New Member

    thank, that indeed was the problem.
     

Share This Page