Forwarded e-mails hitting spam / softfail

Discussion in 'General' started by vibrancy, Jan 13, 2015.

  1. vibrancy

    vibrancy Member

    I've been tickling my brain on this, and it may end up just being the way it works... but I have a few email forwards setup and anytime someone emails the forwarder, when it is received I am getting a softfail and gmail is throwing them in my spam box.

    So - here's a scenario -
    [email protected] emails [email protected] - [email protected] auto forwards to [email protected]
    When [email protected]'s email is received at [email protected] - it results in a softfail because myServer is trying to send the forwarded email as [email protected].
    Received-SPF: softfail ( domain of transitioning [email protected] does not designate as permitted sender);
    I have tried 3 different methods to achieve the forwards and everyone has the same result:
    Method A: Create the account and set up a sieve redirect in mailbox config --> custom rules
    Method B: Create the account and set up "Send copy to" in mailbox config
    Method C: Create an Email Forward using the EMail Forward option in the email tab...

    So, is this just the way it works, or is there some setting I'm missing to get it to work properly?

    Installation info:
    Method of install:
    ISPConfig Version:
    Last edited: Jan 13, 2015
  2. vibrancy

    vibrancy Member

    Further reading - came across:

    Which till suggests that the email script is rewriting the address - and I see that being an issue for some of our other setups, but for this particular setup I am trying to have ISPConfig do the forwarding/routing, it's not an additional script - so how do I get ISPConfig to NOT rewrite the address on forwarded/redirected messages?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfi is not involved at all in forwarding the emails, it just writes config files, The fowarding is done by dovecot for method a and b and by postfix for method c.

    Your problem is most lilely that the forwarded mail is dkim signed and your server is not permitted to do forwards for thhe sender domain of the email or the sender domain of the email uses spf an your server is not in the allowed server list,
  4. vibrancy

    vibrancy Member

    Hi till, thanks for your response. So, basically since I can't get on AOL's record, there's nothing I can do about this then if I want to have that auto-forward functionality?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If the sender addresses (domains) use mechanisms to protect themself so that no other server is allowed to send or forward email for this domain, then there is not mauch that you can do.
  6. vibrancy

    vibrancy Member

    That's what I figured - alright thank you for your help and for clearing it all up! :)

Share This Page